Results 1 to 13 of 13

Thread: 2002 rsv mille Starter solenoid???

  1. #1
    Baby Twin
    Join Date
    Jul 2013
    Location
    Manchester
    Posts
    3

    2002 rsv mille Starter solenoid???

    Hi Guys
    I'm new to this forum and I'm hoping for some advice.
    I suffered a dash reset on my Mille when starting it the other day and now I get nothing than a awful clicking from starter solenoid and relay and constant flickering of dash on pressing the start button. I have tried bridging the terminals on the starter solenoid which does nothing but turn the dash off. Is this the starter solenoid having failed or the battery? The battery is just over 12 months old and kept on a optimate. Any advice greatly appreciated. As far as I'm aware the bike is on the original starter solenoid but no markings on it to say other.
    Kind regards
    Scott

  2. #2
    One Liter Duc Eater nikfubar's Avatar
    Join Date
    Dec 2009
    Location
    Always pissin down with rain Sussex
    Posts
    663
    Your battery's shagged mate, you could try cleaning all the terminals & earth strap points but I expect you will need a new battery, these bikes knock the guts out of them in no time. These are the best ones available at the moment

    Aprilia RSV 1000 R Tuono 2006 CTX12-BS Motobatt Motorcycle Battery Upgrade | eBay

    And you might aswell change your solenoid if you are unsure, this is the one

    New - Aprilia 850 Manna, Pegaso, RSV1000, Shiver 750, Scarabeo - Relay 12v-150a | eBay

  3. #3
    Baby Twin
    Join Date
    Jul 2013
    Location
    Manchester
    Posts
    3
    Cheers its the Yuasa 14 thats on it and the multimeter says its good loaded and unloaded, i have put a test across the starter solenoid and thats 13.6v but once starter is pressed it still carries 6v and from i have read in the starting sticky on here it should be way lower than that more like 0. something.
    Thank you for the advice and any help greatly appreciated

  4. #4
    Baby Twin
    Join Date
    Jul 2013
    Location
    Oban
    Posts
    2
    I'm also new to the forum but can backup what has already been said. I had the same problem with mine, also an 02 model. I replaced the battery, although not the solenoid and its been fine so far.

  5. #5
    Superbike Twin Geoff997's Avatar
    Join Date
    Apr 2013
    Location
    Hinckley Leicestershire
    Posts
    118
    Get a 14 amp battery 150 amp starter solenoid, extra earth strap and solder the yellow wires. I did these plus had it set up at windy corner sound as a pound

  6. #6
    Baby Twin
    Join Date
    Jul 2013
    Location
    France
    Posts
    4

    maybe the same problem?

    Hey guys!!

    i have an 01, i have the same problems. i thought it was the starter, but i took it out tested by connecting directly to the battery on the bike. works perfect.

    then i put the starter back in, and just the solenoid clicking. i tried connecting the starter via the solenoid (starter cable) to see if it spun the starter like this? but the starter wouldn't turn like this. then i connected the starter direct to the battery again and success again with the motor.

    the battery is less than 4 months old? is it the battery for sure or something else??

    thanks

    Paul

  7. #7
    Baby Twin
    Join Date
    Aug 2013
    Location
    Renfrewshire, Scotland
    Posts
    3
    In my experience, battery & solenoid are your first concerns, do these and 9 times out of 10 you'll sort it.
    Also sort the charging system out by cutting out the brown connector & soldering wires, an extra earth strap won't hurt either.

  8. #8
    Baby Twin
    Join Date
    Nov 2010
    Location
    Luton, UK
    Posts
    98
    Quote Originally Posted by aldorossi View Post
    In my experience, battery & solenoid are your first concerns, do these and 9 times out of 10 you'll sort it.
    Also sort the charging system out by cutting out the brown connector & soldering wires, an extra earth strap won't hurt either.
    Quote Originally Posted by Geoff997 View Post
    Get a 14 amp battery 150 amp starter solenoid, extra earth strap and solder the yellow wires. I did these plus had it set up at windy corner sound as a pound
    Can you guys please explain in detail how these mods are done...bear in mind im bloody hopless at all this kinda thing so when I say "explain" I mean "Explain to someone that has no idea"
    Thanks guys

  9. #9
    Superbike Twin CRAZY LEG5's Avatar
    Join Date
    Oct 2010
    Location
    warrington
    Posts
    237
    the battery and solenoid are just a case of swapping original parts out here is a walk through of the brown connector mod RSV Voltage Regulator Wiring Modification

  10. #10
    Baby Twin
    Join Date
    Mar 2013
    Location
    everywhere
    Posts
    37
    Take the advice from geoff997 and you will not go wrong. I did and bike was perfect. Top member is Geoff.

  11. #11
    Baby Twin
    Join Date
    Nov 2010
    Location
    Luton, UK
    Posts
    98
    Ok thx guys. Appreciated a lot.

  12. #12
    Superbike Twin
    Join Date
    Dec 2009
    Location
    Galati, Romania
    Posts
    246
    i don't know if it's cheaper in the UK (in romania it certainly is) but a car solenoid is WAY better. 300+ amps a dacia/renault one in romania costs about 10 pounds...

  13. #13
    Baby Twin
    Join Date
    Dec 2014
    Location
    Asia
    Posts
    69
    Quote Originally Posted by stress View Post
    i don't know if it's cheaper in the UK (in romania it certainly is) but a car solenoid is WAY better. 300+ amps a dacia/renault one in romania costs about 10 pounds...
    wow.. 300amp +?? won't that relay overheat? somebody says, its useless to use very hi amp relay if the we didn't upgrading the battery.. hi amp need hi CCA battery.. but some1 else had tried using this yam relay

    3ay-81940-00-00 from yam virago i believed

Similar Discussions

  1. 12v 150 amp starter solenoid
    By Powerfreak in forum eBay Auctions
    Replies: 9
    Last Post: June 19th, 2014, 04:02 AM
  2. 2002 Rsv Mille starter solenoid??
    By Scooter04 in forum Mechanical and Technical
    Replies: 0
    Last Post: July 28th, 2013, 06:28 AM
  3. think my Starter Solenoid has gone?
    By sanyumwertz in forum Aprilia RSVR
    Replies: 7
    Last Post: October 28th, 2010, 01:26 AM
  4. Starter solenoid
    By Black Sabbath in forum Aprilia RSVR
    Replies: 9
    Last Post: December 23rd, 2008, 01:10 PM

Search tags for this page

Click on a term to search for related topics.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •