Results 1 to 3 of 3

Thread: engine temp and fuel light

  1. #1
    Baby Twin
    Join Date
    Sep 2013
    Location
    la
    Posts
    2

    engine temp and fuel light

    i have an 02 mille that was sitting for like 2 years. got it to start but now the engine temp always says cool even when i got it running over an 1hour. the other problem is the fuel light always says empty even when i have full tank. any suggestion on troubleshooting? thank you.

  2. #2
    Superbike Twin Geoff997's Avatar
    Join Date
    Apr 2013
    Location
    Hinckley Leicestershire
    Posts
    118
    Hi James try cleaning the connections that might help ?? Test the thermostat make sure it's working

  3. #3
    Baby Twin
    Join Date
    Sep 2013
    Location
    la
    Posts
    2
    which connector ? are the fuel level on the fuel pump in side the tank. where is the connector for the temp? thanks

Similar Discussions

  1. Fuel light ?
    By Mikee in forum Aprilia RSV Mille
    Replies: 5
    Last Post: June 25th, 2013, 12:54 AM
  2. engine temp and oil valves cover
    By giorgos in forum Aprilia RSVR
    Replies: 5
    Last Post: August 14th, 2012, 04:26 AM
  3. engine temp
    By cbrpete in forum Aprilia RSVR
    Replies: 9
    Last Post: June 1st, 2009, 10:55 AM
  4. Engine cut out at low temp
    By jake in forum Aprilia RSVR
    Replies: 8
    Last Post: April 27th, 2009, 03:35 AM
  5. Fuel light
    By Ryver in forum Aprilia RSVR
    Replies: 8
    Last Post: May 7th, 2008, 12:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •