Results 1 to 7 of 7

Thread: Crack on the imput shaft housing

  1. #1
    Baby Twin
    Join Date
    Apr 2013
    Location
    Dublin
    Posts
    15

    Crack on the imput shaft housing

    crack1.jpg
    Found this crack this morning. Anyone seen this happen before?

  2. #2
    AMA Pit Boss redratbike's Avatar
    Join Date
    Oct 2010
    Location
    Modding collectors in kent
    Posts
    2,978
    Sure it's a crack and not casting flashing.

  3. #3
    Superbike Twin Dr_D's Avatar
    Join Date
    May 2013
    Location
    East Yorkshire
    Posts
    178
    What he said - I'ld clean and polish the area to see for certain

  4. #4
    Superbike Twin Sensei's Avatar
    Join Date
    Oct 2010
    Location
    Taranaki NZ
    Posts
    193
    Clean with carb clean then Use a Dye Penatrant on case this will tell you 100% if it's a crack !

  5. #5
    AMA Pit Boss redratbike's Avatar
    Join Date
    Oct 2010
    Location
    Modding collectors in kent
    Posts
    2,978
    Quote Originally Posted by Sensei View Post
    Clean with carb clean then Use a Dye Penatrant on case this will tell you 100% if it's a crack !
    hey sensei ...i sent someone after you the other day to sort them a modded collector did he get in touch

  6. #6
    Superbike Twin Sensei's Avatar
    Join Date
    Oct 2010
    Location
    Taranaki NZ
    Posts
    193
    Yea Dude well underway with collector ... As with others I have done I have suggested he try's the front link first as from my testing it made the most significant improvement & needs a lot less setup playing than putting the rear link & front link pipes on . I have made up template pipes that I can just trace their shape and use them to pre mark out the collector ready for cutting the holes out helps a lot ... last pipe I did the links as lobster back joins looked just like a TigCraft system then forgot to get a picture before sending it away to new customer DOH will have to try that again even though alot of time to fabricate & weld .. Cheers for the work

  7. #7
    Baby Twin
    Join Date
    Apr 2013
    Location
    Dublin
    Posts
    15
    So the jury is still out. Had a few mates look at it and some say crack and some say flashing. I'll leave it down to the mechanic next week and see what he thinks.

Similar Discussions

  1. sprag housing
    By pat in forum Classifieds
    Replies: 0
    Last Post: January 23rd, 2014, 09:16 AM
  2. Ohlins crack
    By bollock chops in forum Aprilia RSVR
    Replies: 1
    Last Post: September 12th, 2012, 10:20 AM
  3. Oil filter housing allen bolt
    By Cirrus in forum Aprilia RSVR
    Replies: 7
    Last Post: April 18th, 2012, 01:13 PM
  4. Sprag housing
    By bodien in forum Want to Buy
    Replies: 0
    Last Post: February 2nd, 2010, 03:52 PM
  5. Problems at low imput throttle
    By sergi75 in forum Aprilia RSVR
    Replies: 3
    Last Post: October 17th, 2008, 04:12 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •