Results 1 to 9 of 9

Thread: Oil all over the place....

  1. #1
    Baby Twin
    Join Date
    Mar 2018
    Location
    Hertfordshire
    Posts
    13

    Oil all over the place....

    Hello all,

    Iíve had my gen 1 mille for about a month and ridden it a handful of times, once a ride into central London and back to Herts, lots of traffic and a roads/motorway work.

    I took off the side panel when I replaced the internal fuel lines. Problem is, it was covered in a film of oil. It looks to be both sides of the engine but more on the stator side. There is also oil on the bottom of the engine and
    On the stator cover. I found a bit in the air box but not loads. The inside of the fairing has had a fair bit on it. I wiped the stator cover etc and came back the next day. I could see some new oil on the stator cover and oil filter cover.

    I managed to take some photos and have since cleaned it up but not ridden it. My first thought was crankcase gaskets but itís only done 16k. I have seen a bit of discolouration on the tbís but no wet oil. I really want to believe that its been overfilled and itís the air box puking it out over the engine but it doesnít seem possible. No smoke or sluggishness. It hasnít done many miles in the last couple of years, I think mainly in storage. Perhaps it been topped up before delivery to me. The oil tank and fittings are solid, the cap is fine and nothing is apparently leaking..plus for some reason I canít add any photos.

    My plan is to drop the oil and change the filter, replace with the right amount of oil and clean it to see where itís coming from.

    Would the air box be guilt if itís on both sides and underneath? (itís mainly old dirty looking grungy oil, some new ish stuff).

    Thanks in advance

    Al
    Last edited by Douglie; March 31st, 2018 at 10:51 AM.

  2. #2
    Baby Twin
    Join Date
    Oct 2017
    Location
    Wantage UK
    Posts
    21
    A little oil goes a long way, clean it all up and keep an eye out.

  3. #3
    Baby Twin
    Join Date
    Mar 2018
    Location
    Hertfordshire
    Posts
    13
    Yeah, I hope you’re right mate. I can’t rationally believe that a tidy well kept low mileage machine would be weeping oil out of both sides...although I haven’t had a bike that was sound in quite some time...I hope it’s simple as the bike is epic otherwise.

  4. #4
    AMA Pit Boss redratbike's Avatar
    Join Date
    Oct 2010
    Location
    Modding collectors in kent
    Posts
    2,999
    Valve cover gaskets are notorious for leaking and that goes everywhere check there first

    Is the stator cover leaking if it’s been off for a new sprag maybe it’s not been tightened up enough

    Has the engine been overfilled causing leaks

    Oil in airbox points to an overfill although even the correct amount allows some to get in there

    Check crank breather pipe on rear valve cover isn’t leaking

  5. #5
    Baby Twin
    Join Date
    Mar 2018
    Location
    Hertfordshire
    Posts
    13
    Good shit there, thanks man.

    I’m gonna take everything off and have a look. I went round the crank cases with a torque wrench and a few weren’t up to the proper tightness but I haven’t ridden it since.

    The valve covers look clean and dry and the barrels were looking good. I reckon it might be some old stuff on the engine from a while ago plus some new stuff from the handful of rides it’s been on with me. A couple of three milers and then a 60+mile round trip.

    I’ll update when I get a result.

    Thanks again folks.

  6. #6
    Super Moderator Tash's Avatar
    Join Date
    Mar 2009
    Location
    Co Durham
    Posts
    1,511
    I have got a brand new set of rocker cover gaskets if you need them.
    Cheers

  7. #7
    Baby Twin
    Join Date
    Mar 2018
    Location
    Hertfordshire
    Posts
    13
    Awesome. Thanks a lot. I’ll let you know as soon as I have got in there. Hopefully tomorrow.

  8. #8
    Baby Twin
    Join Date
    Mar 2018
    Location
    Hertfordshire
    Posts
    13
    Right....Stripped the air box off and had a good old look. There’s old yellow oil residue all over the engine, front cam cover and throttle bodies. Plus no catch pipe on the r/h side of the air box. I cleaned everything up and planned to do the oil change but got stopped by the front oil tank fixing...what kind of fixing is that? It’s a bolt through the oil cooler bracket which then has a rubber booted bolt which slots on the top? It’s almost impossible to reattach it. I had a sense of humour failure and knocked it on the head.

    And I still can’t post photos. I assume it’s due to my junior forum status.

  9. #9
    Baby Twin
    Join Date
    Mar 2018
    Location
    Hertfordshire
    Posts
    13
    All done I think.

    Everything looks good with new oil and filter, about 3.5lt of the good stuff. After a 25 minute run there were no leaks and the level was just at the minimum. Topped it up to half way between and all done. I assume that the oil level checking method is so weird that people get it wrong and overfill it.

    The oil filter cover keeps weeping at the very bottom and I can’t find the torque setting for it but that’s no issue really. The book says 30Nm...no way.

    Thanks for all the advice folks.

    Al

Similar Discussions

  1. best place to buy parts
    By Hessler in forum Aprilia RSV Mille
    Replies: 4
    Last Post: February 5th, 2018, 02:53 AM
  2. Best place to buy parts?
    By RolBer in forum Aprilia RSVR
    Replies: 4
    Last Post: August 11th, 2009, 08:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •