Results 1 to 5 of 5

Thread: No start + clicking noise

  1. #1
    Baby Twin
    Join Date
    Jun 2018
    Location
    Netherlands
    Posts
    2

    No start + clicking noise

    Hey guys,

    I'm new to this forum. Just picked up my first bike. An 2001 RSV Mille. Offcourse I had to show it off a bit and let people hear how it sounds. I have started the bike 3 times in 2 days, just idling. I have no licence yet so I can't take it for a spin.

    This afternoon I wanted to start the bike again. I turned te key and immediately heard a clicking noise from underneath the backseat (the starter relay a assume). Tried to start the bike and it turned over but wouldn't start.

    Offcourse I did some research about this problem. Found out really quick that the battery is a common problem and the starter relay. But because the bike is turning over, I don't think it's possible the starter relay is dead.

    Could it be that the battery died because of starting it a couple of times without giving it a change to charge?

    Verstuurd vanaf mijn HUAWEI VNS-L31 met Tapatalk

  2. #2
    Baby Twin
    Join Date
    Jul 2017
    Location
    West of England
    Posts
    14
    Seriously, don't try to start it again until you are sure the battery is fully charged: it takes a lot of amps to turn a big twin over, and if the engine turns over but not fast enough to start it can backfire and wreck the starter clutch.

    Also, don't give it any throttle until it's running, for the same reason.

    these good folk can do you an upgraded battery and starter solenoid: https://www.apriliaperformance.co.uk/

    At very least, especially if you aren't going to be riding regularly for a while, get an Optimate charger and lead.

  3. #3
    Baby Twin
    Join Date
    Jun 2018
    Location
    Netherlands
    Posts
    2
    Thanks for your comment!

    That upgraded solenoid and battery is definitely something to keep in mind!

    But I dit some more research this evening en found out that the fuel pump isn't turning on when turning te key. En the clicking is coming from te relais as show in the picture. I guess this is the fuel pump relay then? So I'm guessing that relay died en that's why the motor won't start!

    Could I be right, and if so, where can you buy the relays?

    Verstuurd vanaf mijn HUAWEI VNS-L31 met Tapatalk

  4. #4
    Baby Twin
    Join Date
    Jul 2017
    Location
    West of England
    Posts
    14
    Interesting...you could try a car parts factor to see if the relay is a generic part...for instance Ducati cam belts which cost 70 a shot here can be had (exactly the same part) from Renault dealers for about 30, I believe.

    Failing that, aprilia performance, which I linked to in my first reply, can probably help you. They have an excellent reputation here.

  5. #5
    Superbike Twin Hertsrsvr's Avatar
    Join Date
    Feb 2017
    Location
    Herts, england
    Posts
    136
    Or just do a Google search with the numbers on the relay. They a bog standard relays, they are cheap, but if you buy from aprilia or vw they are expensive !
    Glad you are working through the problems, it's well worth it when you have your ape working well....

Similar Discussions

  1. Not starting / Clicking noise
    By archad71 in forum Aprilia RSVR
    Replies: 7
    Last Post: August 25th, 2014, 09:48 AM
  2. Bloody clicking noise
    By Egghead in forum Aprilia RSVR
    Replies: 7
    Last Post: December 29th, 2012, 09:07 AM
  3. Clicking and now not starting
    By leenineplus in forum Aprilia RSVR
    Replies: 15
    Last Post: May 29th, 2012, 03:20 PM
  4. Clicking Noise?
    By Garvey2003 in forum Aprilia RSVR
    Replies: 12
    Last Post: January 15th, 2011, 02:05 PM
  5. HELP!! ECU Clicking
    By Olek in forum Aprilia RSVR
    Replies: 35
    Last Post: March 6th, 2009, 10:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •