Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Thread: any bad points for the rsv4 ????

  1. #1
    Evil Twin mad biff's Avatar
    Join Date
    Apr 2011
    Location
    scotland
    Posts
    454

    any bad points for the rsv4 ????

    hi guys i should have mine soon i hope but need to book test ride first to see if i like it has anyone got any bad things to say about the rsv4 i would like to hear your comments i know its a small bike and im 6ft could be a sore ride lol

  2. #2
    Baby Twin kingfixer's Avatar
    Join Date
    Oct 2010
    Posts
    89
    Im 6ft1 and i have no problems on it size wise, but i have fitted some rearsets to make it a better fit!!. If you look around the different forums you should see the sort of things that might happen, minor oil leaks etc.
    But it is a superb bike and i love it

  3. #3
    Baby Twin BobC's Avatar
    Join Date
    Jun 2011
    Posts
    21
    I found that having no span adjustment on the clutch lever was a problem but easily fixed with some ASV levers which look extremely nice too. Also I sometimes move the mode switch instead of the indicator switch but I expect I'll do that less as I get used to the bike. Only 100 miles before reserve could be a problem for some. Otherwise I think it's a great bike and I particularly like the attention to detail in the design and build. Everywhere you look you can see that someone has put a bit of thought and passion into it.

    One more point I just remembered, I find that in bright light the reflection of the top yoke in the speedo makes it hard to read, all I can see is the reflection of the bright alloy yoke. I'm thinking of applying some matt black paint to the front edge.
    Last edited by BobC; June 9th, 2011 at 01:20 AM.

  4. #4
    Baby Twin
    Join Date
    Jun 2011
    Location
    Scotland
    Posts
    8

    Angry

    I've had both the 'R' and now the APRC SE. The first one was recalled due to con rod issues. The second one the 'top of the range' is now sitting back at the dealers with only 600 miles on it as it won't start. Think twice before you part with your cash!!

  5. #5
    Baby Twin kingfixer's Avatar
    Join Date
    Oct 2010
    Posts
    89
    Mine wouldn't start when i got mine as well, my dealer arranged for an Aprilia technician to come out and he installed a map on the bike for starting the engine??. Worked perfect ever since!!
    That was last year when i bought a brand new 10 plate.
    Although i have heard recently there is a problem with the starter motors on some bikes.
    Last edited by kingfixer; June 9th, 2011 at 11:57 PM.

  6. #6
    Baby Twin BobC's Avatar
    Join Date
    Jun 2011
    Posts
    21
    Mine's a 2010 Factory on an 11 plate and it stays plugged-in to an Optimate when it's in my garage. I've done this with all my bikes for the last several years and not had any problems so far.

    Is the failure to start a batch problem, can Piaggio identify which bikes might be affected, or is it just random?

  7. #7
    Baby Twin kingfixer's Avatar
    Join Date
    Oct 2010
    Posts
    89
    Random i think, i think all RSV4 owners get random problems!!
    If i left mine for more than 1 day with out starting it it wouldn't, I bought mine from Metropolis in London, they had a tech guy from Aprilia turn up to install a fuelling map for starting the bike only!!. Apparently mine was the 1st bike to have this done and the guys in the workshop weren't allowed to watch him do it !! pathetic really. I have had a complete engine rebuild on mine due to oil leaks etc (under warranty)

  8. #8
    Baby Twin BobC's Avatar
    Join Date
    Jun 2011
    Posts
    21
    Thanks, I'll keep my fingers crossed then. Just ordered an Akrapovic slip-on so I'll have a good look round when I take the bodywork off to fit it.

  9. #9
    Baby Twin kingfixer's Avatar
    Join Date
    Oct 2010
    Posts
    89
    I have the Austin Racing GP2 slip on fitted to mine.

  10. #10
    Baby Twin BobC's Avatar
    Join Date
    Jun 2011
    Posts
    21
    Nice, I looked at Austin Racing's goodies but I really need to stay road-legal at the moment. I had a TiForce system on my ZZR which I used for top speed events and every time I rode it to one of our meetings or shows down in the Westcountry, instead of putting it in a van, I was acutely aware of the attention it attracted. Couldn't open her up without all hell breaking loose. I had the road-legal Akrapovic on my Blade and it was a reasonable compromise for road use.

  11. #11
    Baby Twin
    Join Date
    Jun 2011
    Location
    Scotland
    Posts
    8
    Optimate ain't going to make much of a difference. I fitted a brand new battery as the fault, or the symptoms, are very similar to a 'flat' battery. I was informed yesterday the new 'type' starter motor is on it's way. As soon as it's fitted I'm off to trade in against the 1198 SP. Can't be bothered with the hassle any longer!!

  12. #12
    Baby Twin
    Join Date
    Mar 2011
    Posts
    1
    Strange with the startermotortrouble, I had mine APRC for 1500 miles now and no problem whatsoever, wonderful bike, even if the 1198SP also is a real awsome bike, I'd keep the Ape
    every day in the week:-)

  13. #13
    One Liter Duc Eater Carbon Kid's Avatar
    Join Date
    Oct 2010
    Posts
    646
    I havent had any starting probs eiyther..and I use an optimate.
    Its a thirsty bike, if you are really on it you can hit the red light in 65 miles, but brilliant fun.
    Very stiff and short bike, awesome
    ck

  14. #14
    Baby Twin BobC's Avatar
    Join Date
    Jun 2011
    Posts
    21
    Fuel economy is not an issue for me but I read somewhere else that loading an APRC map onto an RSV4 Factory improved the mpg. I have no other details and don't know if it's safe to do. Has anyone heard about this?

  15. #15
    One Liter Duc Eater Carbon Kid's Avatar
    Join Date
    Oct 2010
    Posts
    646
    I always run in T mode, its more frugal in the other modes apparently, .not that I care lol.
    I got the Ti Akra race which I would recommend as it has a removable baffle..and a lovely sound
    ck

  16. #16
    Evil Twin Valendino's Avatar
    Join Date
    Jun 2008
    Location
    Waihi, New Zealand.
    Posts
    284
    Only problem I have had with mine is that it is toooo fast for the road, so it is now getting prepared for the up coming race season and I will just keep using my old 01 Mille R for the road

  17. #17
    Baby Twin
    Join Date
    Apr 2011
    Posts
    1
    Hi Guys,

    Have had my new RSV4 APRC SE for 2 weeks now the one think I have noticed is that the exhaust valve doesn't open when clicked into gear like on the old RSV4.

    I have spoken to the dealer and they are surprised and are chasing it up with Aprilia. Has anyone else noticed this. New exhaust goes on at 1st service.

    Apart from this I love the bike, I do occassionally get the blinker and mode mixed up.
    Neils60

  18. #18
    One Liter Duc Eater Carbon Kid's Avatar
    Join Date
    Oct 2010
    Posts
    646
    get an akra, jobsa good'un!!!
    ck

  19. #19
    Baby Twin
    Join Date
    Jun 2011
    Location
    Scotland
    Posts
    8
    New starter motor arrived and seemingly the fault is cured. I won't be picking the bike up for a week due to work commitments but I'll give the RSV4 SE and aprilia one last chance. I also noticed there was no difference in exhaust note on the SE when clicking into first unlike the first RSV4's

  20. #20
    Baby Twin
    Join Date
    Aug 2009
    Posts
    19
    Hi guys over 700 race miles at an average of 117 mls per hr plus all the practise laps as well no problems sofar just a lot of petrol and tyres 3 pairs of slicks plus 3 pairs of pirelli supercorsas think about 800 pounds for petrol in two weeks been lying low since then but should be at Melville club meet next weekend at Eastfortune.bar and band on Sat night if anybody looking for some place to go.

Page 1 of 2 12 LastLast

Similar Discussions

  1. Bike Camera Mount Points
    By amb67 in forum Motorcycle Talk
    Replies: 15
    Last Post: October 21st, 2009, 06:34 AM
  2. Replies: 0
    Last Post: October 5th, 2009, 06:43 PM
  3. RSV Clutch Bite Points??
    By amb67 in forum Aprilia RSVR
    Replies: 2
    Last Post: September 27th, 2008, 10:36 AM
  4. How many points ?
    By Gasboy in forum Aprilia RSVR
    Replies: 17
    Last Post: October 14th, 2007, 02:30 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •