Results 1 to 7 of 7

Thread: Coolant leak - but only on the move

  1. #1
    Baby Twin
    Join Date
    Nov 2012
    Location
    Surrey
    Posts
    23

    Coolant leak - but only on the move

    Hi

    My track bikes come up with a mysterious coolant leak.

    RSV4 2014 factory ABS

    basically levels are fine and when fired up at a standstill and let it get up to temperature there's no leaks anywhere. Prod/waggle the hoses still no leaks.

    Go out for a session on a track day and come back with a belly pan with about half a litre of fluid in it - it's green so its definitely coolant.

    The catch tank still has roughly the original amount so I'm suspecting it's come directly form the cooling system - the hose from the radiator to the catch tank is clear of blockages - just not sure where from and if it's the movement or the track fairing rubbing against anything.

    Obviously difficult to test ride without shelling out for a track day or converting back to road use and getting a dealer to look at it.

    Anyone seen this before or had it happen to them.

    Thanks

    Chris

  2. #2
    Baby Twin
    Join Date
    Dec 2010
    Location
    Northwest
    Posts
    7
    Hi Chris, I've had the same problem with my RSV4 2014 Factory ABS model. Took it to Rocket Centre Aprilia dealer and they replaced the water pump under warranty.
    Regard, Koh

  3. #3
    Baby Twin
    Join Date
    Nov 2012
    Location
    Surrey
    Posts
    23
    thanks Koh,

    Looks like I need a new water pump then - any idea what it was doing - presumably over pressurising the system at higher revs.

    Cheers

    Chris

  4. #4
    Baby Twin
    Join Date
    Dec 2010
    Location
    Northwest
    Posts
    7
    Hi Chris, I'm not mechanically minded so don't know the exact problem, but straight after they replaced the water pump it began leaking again. I took it back to them to find they hadn't tightened the jubilee clip. Can you believe it?!?!?! So it may not have been the water pump in the first place lol
    Regards, Koh

  5. #5
    Baby Twin
    Join Date
    Nov 2012
    Location
    Surrey
    Posts
    23
    Have got hold of a spare water pump (not fitted yet) and swapped the radiator cap and jubilee clip and hose to catch tank as leak seemed to be from the top right of radiator area somewhere. Have another track day tomorrow so will find out if that fixed it and if not swap the water pump and hope that does.

    Cheers
    Chris

  6. #6
    Baby Twin
    Join Date
    Nov 2012
    Location
    Surrey
    Posts
    23
    looks like it was the jubilee clip - replaced that and the radiator cap and it hasn't happened since and I can't see anything wrong with the radiator cap.

  7. #7
    Baby Twin
    Join Date
    Dec 2010
    Location
    Northwest
    Posts
    7
    Nice simple fix! ����

Similar Discussions

  1. Coolant leak
    By Richy0317 in forum Aprilia RSVR
    Replies: 3
    Last Post: February 19th, 2015, 03:20 AM
  2. Coolant leak?
    By penyrolewen in forum Aprilia RSVR
    Replies: 4
    Last Post: September 26th, 2014, 07:47 AM
  3. Coolant leak
    By Bol D'or in forum Aprilia RSVR
    Replies: 10
    Last Post: December 21st, 2013, 07:19 AM
  4. Coolant leak + overheating
    By Joe1232005 in forum Aprilia RSVR
    Replies: 6
    Last Post: November 5th, 2011, 05:01 AM
  5. Coolant Leak help please
    By Neil B in forum Aprilia RSVR
    Replies: 5
    Last Post: March 17th, 2008, 08:34 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •