Results 1 to 7 of 7

Thread: why why why - there just indicators - help!!

  1. #1
    OZMILLE
    Guest

    why why why - there just indicators - help!!

    OK

    All was good there for awhile, until I changed the indicators.

    Now I didnt go for the LED, didnt want the hassle, just some smarter bulb units..................COOL RIGHT................

    Well I changed the plug'n play set up already there to individual male/female connectors to get the extra length...........just used normal 3mm car connectors and this is now what happens.

    Both rears work fine (with the fronts disconnected), neither front ones work at all, they just stay lit ............. when all connected together nothing works............

    Can anyone please shed some light, surely the connectors cant be the problem, can THEY??

    Cheers Pete

  2. #2
    AMA Pit Boss
    Join Date
    Sep 2008
    Location
    Shoeburyness, Essex
    Posts
    2,338
    okay, what wattage bulbs did you use ??

    also did you change the wires like for like (as in +ve -ve ) ?

  3. #3
    OZMILLE
    Guest
    Quote Originally Posted by Kiwi_rsvr View Post
    okay, what wattage bulbs did you use ??

    also did you change the wires like for like (as in +ve -ve ) ?
    Hey Kiwi

    I have no idea mate, just bought some nice after market units??

    I know this may sound stupid, I thought as long as one wire plugs into another then its all on a ciruit type thingy.........NOT GOOD HA

    Please set me straight my friend

  4. #4
    AMA Pit Boss
    Join Date
    Sep 2008
    Location
    Shoeburyness, Essex
    Posts
    2,338
    If the bulbs are the wrong wattage (too much or too little)the flasher relay wont be able to drive them. what you need is to get a wideband electronic flasher relay (Motrax and the like make them retail for around 20 UKP, these will do LED's as well)

  5. #5
    Superbike Twin deej's Avatar
    Join Date
    Aug 2009
    Location
    isle of man
    Posts
    120
    Had the same problem fella.. i fitted some Mottrax indicators which have 23w bulbs,the original indicator bulbs are 10w. Just get some motrax 10w bulbs around 6 for two..

  6. #6
    amb67
    Guest
    Just get a cheapo 10 LED relay off Flea Bay and then you can run what you want.

    Click Me for Flea Bay

  7. #7
    OZMILLE
    Guest
    Cheers for that guys, will try a couple of correct bulbs 1st, then if no success will get the relay..................

Similar Discussions

  1. indicators
    By apecolin in forum Want to Buy
    Replies: 2
    Last Post: December 20th, 2011, 12:02 AM
  2. What indicators has he on his RSV
    By AREESSMILL in forum Aprilia RSVR
    Replies: 15
    Last Post: November 28th, 2009, 09:10 AM
  3. LED indicators
    By Gravelrash in forum Aprilia RSVR
    Replies: 10
    Last Post: April 2nd, 2009, 05:19 AM
  4. Indicators
    By supertedlover in forum Aprilia RSVR
    Replies: 5
    Last Post: August 19th, 2008, 11:37 AM
  5. Indicators
    By rockdoctor in forum Aprilia RSVR
    Replies: 19
    Last Post: September 13th, 2007, 04:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •