Results 1 to 8 of 8

Thread: Clocks......

  1. #1
    Superbike Twin Redlight's Avatar
    Join Date
    Mar 2009
    Location
    Newton Abbot
    Posts
    129

    Clocks......

    I have an 04 RSVR with an amnesiac speedo. Every time I disconnect the battery it looses all settings. It should have been fixed as part of a recall but the previous owner never did. My problem is it has now forgotten MPH and will only show KPH. I have tried the handbook (TripV +- for 15 seconds) and nothing! Any ideas?

    Thanks.......

  2. #2
    BB1000
    Guest
    The buttons can be tricky.....try it again with 2 pens

    Alot of 04 bikes have resetting clocks...including mine

  3. #3
    Superbike Twin Redlight's Avatar
    Join Date
    Mar 2009
    Location
    Newton Abbot
    Posts
    129
    Thanks........I will try the pens. They must be most godawful buttons in existence.

  4. #4
    Superbike Twin Redlight's Avatar
    Join Date
    Mar 2009
    Location
    Newton Abbot
    Posts
    129
    I managed to sort this. I disconnected the battery again and waited for everything to reset to zero. Then was able to reset back to MPH as normal.

  5. #5
    BB1000
    Guest
    cool......and i agree, the buttons aint for big fingers

  6. #6
    Superbike Twin knightster's Avatar
    Join Date
    Oct 2009
    Location
    Plymouth
    Posts
    185
    they are a pain ain't they? i got myself right worked up one night and made my soft office fingers red raw trying to set to MPH, would the buttons respond? would they bollox..... used a chunky 6mm allen key to press the buggers in and hey presto!! worked a treat!

  7. #7
    Superbike Twin Redlight's Avatar
    Join Date
    Mar 2009
    Location
    Newton Abbot
    Posts
    129
    Quote Originally Posted by knightster View Post
    made my soft office fingers red raw trying to set to MPH,
    Had to laugh.....I know exactly how you feel. Clicking my biro is a strain.

  8. #8
    One Liter Duc Eater ukcustombike's Avatar
    Join Date
    Nov 2008
    Location
    Not far from you!
    Posts
    628
    Glad you got it sorted.

    I had exactly the same problem last year, on one occassion the clocks reset then it went from MPH to KPH a few weeks later, i couldnt change it back so i disconnected the battery and fortunatly they went back to MPH, dame things!

    Thanks for the tip, im glad im not the only one thats had trouble with these buttons.

Similar Discussions

  1. clocks
    By zubes247 in forum Aprilia RSVR
    Replies: 2
    Last Post: February 5th, 2013, 11:43 AM
  2. Clocks
    By PaulW in forum Aprilia RSVR
    Replies: 3
    Last Post: October 25th, 2011, 04:33 PM
  3. rsv clocks
    By diabolico in forum Aprilia RSVR
    Replies: 0
    Last Post: November 26th, 2009, 09:53 AM
  4. RSV CLocks
    By bignuts in forum Want to Buy
    Replies: 0
    Last Post: June 16th, 2009, 12:20 PM
  5. Clocks
    By dangleebals in forum Want to Buy
    Replies: 6
    Last Post: March 8th, 2009, 12:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •