Results 1 to 4 of 4

Thread: Immobiliser

  1. #1
    Baby Twin bigbaz222's Avatar
    Join Date
    Jan 2011
    Location
    leicester
    Posts
    61

    Immobiliser

    Picked my 03 factory up yesterday not had time till today to really look over it (due to a bloody household plumming emergency yesterday!!) great bike but have noticed the immobiliser light stays on all the time even when the bike is running (hand book says it should blink when the keys out and go off when the bikes turned on) any ideas on whats up with it? cheers Baz

  2. #2
    Retired
    Join Date
    Oct 2010
    Posts
    491
    Quote Originally Posted by bigbaz222 View Post
    Picked my 03 factory up yesterday not had time till today to really look over it (due to a bloody household plumming emergency yesterday!!) great bike but have noticed the immobiliser light stays on all the time even when the bike is running (hand book says it should blink when the keys out and go off when the bikes turned on) any ideas on whats up with it? cheers Baz
    The immobilisor ecu on on the left side inner fairing panel. Because of it's location the ecu and the connectors around it are prone to corrosion and water ingress. Check the big white connector for bad connections first just above the ecu. The Ecu has ZARDI on the platic case. Failing that it could be the ecu itself or even the dash (less likely). There is a thread on here where someone pulled the ecu apart and fixed the water damage and re sealed it. Can't remeber who it was but a search may find it.

    If you have to replace the ecu then you need a dealer or someone with a master key to program the ecu to the chip in your keys but hopefully just connections.

  3. #3
    Baby Twin bigbaz222's Avatar
    Join Date
    Jan 2011
    Location
    leicester
    Posts
    61
    Thanks for that spoonz I will check it out !

  4. #4
    Retired
    Join Date
    Oct 2010
    Posts
    491
    I just checked the service manual and a solid light means the ecu key memory is blank and not programmed to the ignition key.

    Has it had a new immobilisor ecu fitted do you know. If it has try this.

    STORING NEW KEY CODES (VIRGIN MEMORY)

    When the immobilizer ECU is first powered up, its memory is
    virgin and the led stays on without flashing. To store the first
    two key codes :
    - run a key ON cycle with the first key: the led will switch
    off for 0.5 sec and turn on again. When it turns on, turn
    the key to OFF.
    - turn the second key supplied to ON within 20 seconds.
    The led will switch off and immediately flash 4 times.
    Now turn the key to OFF. The two keys are now stored and
    the immobilizer is activated (led flashes every 3 seconds as
    a warning).
    The two keys are now stored and the immobilizer is activated
    whenever the key is turned to OFF (led flashes every 3 seconds
    as a warning)
    If power fails after the first key is stored, the system will reset
    (first key data also cancelled). After the first key has been
    stored, all vehicle and dashboard’s functions are enabled.
    The key is not stored definitively if the second key is not
    stored within 20 seconds.

Similar Discussions

  1. Immobiliser/alarm
    By bigbaz222 in forum Aprilia RSVR
    Replies: 11
    Last Post: September 13th, 2015, 11:44 PM
  2. Immobiliser is it possible to bypass?
    By Russ_79 in forum Aprilia RSVR
    Replies: 5
    Last Post: July 15th, 2014, 09:56 AM
  3. Immobiliser ecu
    By adzersv in forum Aprilia RSVR
    Replies: 4
    Last Post: March 18th, 2009, 07:38 AM
  4. Immobiliser Problem
    By TwistedToFit in forum Aprilia RSVR
    Replies: 3
    Last Post: March 9th, 2009, 07:23 AM
  5. Immobiliser fault or worse??
    By fzrtim in forum Aprilia RSVR
    Replies: 7
    Last Post: June 26th, 2008, 09:50 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •