Results 1 to 8 of 8

Thread: efi light flashing

  1. #1
    Superbike Twin gizgrey's Avatar
    Join Date
    May 2011
    Location
    doune stirling
    Posts
    202

    efi light flashing

    noticed my efi on the dasboard was flashing,only when accelerating hard,its fine when cruising just temp showing,as soon as i crack it open efi flashes...any ideas
    aprilia you got too love them.

  2. #2
    pat
    pat is offline
    Evil Twin pat's Avatar
    Join Date
    Oct 2010
    Location
    Inveraray,Argyll
    Posts
    474
    check your battery connections..

  3. #3
    Baby Twin
    Join Date
    Jun 2011
    Location
    in a house
    Posts
    18
    Quote Originally Posted by gizgrey View Post
    noticed my efi on the dasboard was flashing,only when accelerating hard,its fine when cruising just temp showing,as soon as i crack it open efi flashes...any ideas
    aprilia you got too love them.
    i switch my ignition on the usual efi comes on and off fuel pump primes ,but after i start it sometimes the efi flashes again am wondering same thing do i have something starting too go wrong......

  4. #4
    Superbike Twin St0rmer66's Avatar
    Join Date
    Oct 2010
    Location
    North Yorkshire
    Posts
    108

  5. #5
    Baby Twin
    Join Date
    Jun 2011
    Location
    in a house
    Posts
    18
    Quote Originally Posted by St0rmer66 View Post
    sound buddy i joined up cheers for the linky.......

  6. #6
    Superbike Twin gizgrey's Avatar
    Join Date
    May 2011
    Location
    doune stirling
    Posts
    202
    tightened up battery connections runs perfect no lights on now thanks for the info i would never have thought it..

  7. #7
    pat
    pat is offline
    Evil Twin pat's Avatar
    Join Date
    Oct 2010
    Location
    Inveraray,Argyll
    Posts
    474
    Quote Originally Posted by gizgrey View Post
    tightened up battery connections runs perfect no lights on now thanks for the info i would never have thought it..
    good stuff,always start with the simple things...

  8. #8
    Evil Twin fusebox's Avatar
    Join Date
    Nov 2010
    Posts
    281
    Good call pat!

    You the man!

    Griff

Similar Discussions

  1. RSVR '05 No start, Red triangle, immobilizer flashing
    By grahamir in forum Aprilia RSVR
    Replies: 12
    Last Post: September 10th, 2014, 04:58 AM
  2. EFI light, oil pressure light, why?
    By Baz in forum Aprilia RSVR
    Replies: 25
    Last Post: August 22nd, 2014, 07:13 AM
  3. EFI warning flashing
    By mikerabbit in forum Aprilia RSVR
    Replies: 1
    Last Post: February 18th, 2012, 10:06 AM
  4. Flashing red light thingy on instrument panel.
    By sneakysam in forum Aprilia RSVR
    Replies: 6
    Last Post: May 31st, 2011, 02:28 PM
  5. 99 carbon fibre light cowl and led clear light
    By Bigkev in forum Aprilia RSVR
    Replies: 0
    Last Post: April 22nd, 2011, 08:49 AM

Search tags for this page

Click on a term to search for related topics.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •