Results 1 to 6 of 6

Thread: Coolant Leak help please

  1. #1
    Evil Twin Neil B's Avatar
    Join Date
    Jan 2008
    Location
    North Yorkshire
    Posts
    389

    Coolant Leak help please

    Right guys, i have been out this morning for a blast and the bikes running great with the renne airbox mod
    BUT i'm getting a small amount of coolant spraying out of the cap on the coolant expansion tank
    I thought it would come out of the overflow pipe but it is coming out under pressure from the cap and i've checked that the pipes are clear of crap.
    Any ideas

  2. #2
    One Liter Duc Eater DaveRSV's Avatar
    Join Date
    Nov 2007
    Location
    Northampton
    Posts
    831
    My first thought was that the overflow was blocked. Are you sure it's not become kinked somewhere? You shouldn't get pressure in the expansion tank at all really so something is amiss somewhere.

    There is a 3 way thermostatic valve in the system, is that functioning correctly? It appears to be on the offside of the bike towards the bottom, looking at the diagram in the manual. Three pipes connected to it.

    My guess would be that for some reason the coolant isn't circulating and too much heat is generating too much pressure causing it to blow back into the expansion tank which isn't designed to handle any pressure. What temperature was the engine running at? You'll have to watch that as you could seize the engine if it gets too hot while running.

    I think I'd locate that thermstatic valve, take the bike for a short run to get it up to operating temperature and then feel all the coolant pipes. If the circulation isn't good you should find one that's either a lot cooler or a lot hotter than the rest. The blockage/fault is going to be near there.

  3. #3
    Badger
    Guest
    It is common, nearly all mine have done it, it is only minimal and nothing to worry about, but keep your eye on it in case it is more than that

  4. #4
    Evil Twin Neil B's Avatar
    Join Date
    Jan 2008
    Location
    North Yorkshire
    Posts
    389
    It's off to have a PC3 fitted and some dyno time on Thursday so maybe i should of mentioned that i was doing a bit more than 160
    Took the side panel and expansion tank off, checked all the pipes and coolant level.
    The bike runs fine and the fans come on at 90c and normal running temp is 70 ish.

  5. #5
    One Liter Duc Eater DaveRSV's Avatar
    Join Date
    Nov 2007
    Location
    Northampton
    Posts
    831
    Doesn't sound like you have too much of a problem there then mate, especially after Badger's comments above

  6. #6
    Evil Twin Neil B's Avatar
    Join Date
    Jan 2008
    Location
    North Yorkshire
    Posts
    389
    Think i might take the side panel off when it's on the dyno and get a better idea of where its coming from. Like i said, it only happens when it's being ridden hard but i would like to stop it rather than live with it

Similar Discussions

  1. Coolant leak
    By Richy0317 in forum Aprilia RSVR
    Replies: 3
    Last Post: February 19th, 2015, 04:20 AM
  2. Coolant leak + overheating
    By Joe1232005 in forum Aprilia RSVR
    Replies: 6
    Last Post: November 5th, 2011, 06:01 AM
  3. Which Coolant?
    By abornemonkey in forum Aprilia RSVR
    Replies: 2
    Last Post: January 12th, 2010, 02:09 AM
  4. coolant desappeared
    By diabolico in forum Aprilia RSVR
    Replies: 4
    Last Post: August 18th, 2009, 10:58 AM
  5. Advice needed - coolant leak
    By chicofreemo in forum Aprilia RSVR
    Replies: 6
    Last Post: January 2nd, 2009, 06:45 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •