Results 1 to 6 of 6

Thread: RSVR Gen 2 dying on take off..

  1. #1
    Baby Twin
    Join Date
    Oct 2011
    Posts
    2

    RSVR Gen 2 dying on take off..

    Hi guys,

    I am just about to purchase an Aprilia RSV1000R Factory, 2005 model, with 3700km on the clock!
    The bike has a wierd issue though, it seems to rev fine in neutral but when you put it in gear and release the clutch, the revs go up a little as you feed throttle but then die down after rolling half a meter forward... I am getting the bike for a reasonable price but would still like to know what am I in for...

    Another point to note is that the rpm die off (takes a couple of seconds), and not cut off suddenly.. Even if I do get the bike rolling with some clutch abuse, it seems slightly low on power, maybe it was just me expecting it to be faster.. .

    Lastly, it can take upto 2-3 cranks to start it up at times...

    Yes the side stand is up!

    Any help will be highly appreciated...!

  2. #2
    Superbike Twin
    Join Date
    Dec 2009
    Location
    Galati, Romania
    Posts
    246
    sidestand switch

  3. #3
    One Liter Duc Eater Carbon Kid's Avatar
    Join Date
    Oct 2010
    Posts
    646
    sounds like the TPS or CPS matey (crank or throttle position sensors)
    ck

  4. #4
    Baby Twin
    Join Date
    Oct 2011
    Posts
    2
    UPDATE: Took the bike for a ride today to find out that the exhaust cans are getting red hot after 10km of riding and the bike felt powerless... I believe if running too lean, any inputs as to what could be causing it?

  5. #5
    Superbike Twin
    Join Date
    Dec 2009
    Location
    Galati, Romania
    Posts
    246
    definetly not the sidestand switch then! as carbonkid said, check the tps/cps

  6. #6
    Baby Twin
    Join Date
    Oct 2010
    Posts
    1
    try the idle control valve, on the bottom right side of airbox. its a plunger worked by a steppar motor that bypasses air passes the throttle bodies. Mine sticks sometimes and makes the engine run lean and hot, and the idle is all over the place. I take mine out and clean the white piston with some wire wool and its fine, for a while.

Similar Discussions

  1. Bike keeps dying....
    By Moggi in forum Aprilia RSVR
    Replies: 6
    Last Post: July 14th, 2011, 02:27 PM
  2. Bike Dying
    By cwilliams in forum Aprilia RSVR
    Replies: 10
    Last Post: September 5th, 2009, 12:05 PM
  3. the bitch keeps dying
    By owdlove44 in forum Aprilia RSVR
    Replies: 5
    Last Post: June 12th, 2009, 03:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •