Results 1 to 5 of 5

Thread: help needed indicator prob

  1. #1
    Baby Twin
    Join Date
    Jan 2013
    Location
    portsmouth
    Posts
    13

    help needed indicator prob

    hi can any one help had a problem with my rsv when i give my bike some beans at around 6500 8000 rpm indicator comes on getting a bit dangerous now just giving it a winter clean and would like to sort it out has any one els had same problem cheers

  2. #2
    Baby Twin bollock chops's Avatar
    Join Date
    Oct 2010
    Posts
    56
    Never heard of that one before might pay to replace the relay behind the clocks has it got an alarm on it ?

  3. #3
    Baby Twin bollock chops's Avatar
    Join Date
    Oct 2010
    Posts
    56
    Also check for any loose connections front and back

  4. #4
    Baby Twin
    Join Date
    Jan 2013
    Location
    portsmouth
    Posts
    13
    yep got factory alarm may just do that replace relay, its just like puting indicators on but does it self cant find any loose conections have heard of it befor but cant remember were from

  5. #5
    Baby Twin bollock chops's Avatar
    Join Date
    Oct 2010
    Posts
    56
    It might be a faulty indicator switch try cleaning the contacts and adding a bit of wd40

Similar Discussions

  1. poss clutch prob
    By sparky1 in forum Aprilia RSVR
    Replies: 1
    Last Post: July 27th, 2009, 01:16 PM
  2. rev limiter prob i think
    By iank in forum Aprilia RSV4
    Replies: 4
    Last Post: June 2nd, 2009, 07:47 AM
  3. solenoid prob
    By delmonk in forum Aprilia RSVR
    Replies: 7
    Last Post: May 29th, 2009, 03:06 AM
  4. 06 Tuono dash Prob
    By Flick in forum Aprilia RSVR
    Replies: 4
    Last Post: February 26th, 2009, 08:18 AM
  5. Stator prob
    By bad boy in forum Aprilia RSVR
    Replies: 15
    Last Post: November 28th, 2008, 04:28 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •