Results 1 to 7 of 7

Thread: '04 RSVR white smoke on start

  1. #1
    Baby Twin seoulja702's Avatar
    Join Date
    Oct 2012
    Location
    Oahu, Hawaii
    Posts
    4

    Exclamation '04 RSVR white smoke on start

    So the story is I picked up my bike during lunch today and it started fine. Rode over to the dry cleaners to drop off a uniform and parked like normal. When I returned to my bike, everything was normal until I hit the ignition. The dash went through the start-up sequence as normal; however as soon as it the engine turned over, *poof, white smoke came up from under the dash. I immediately turned the key to off and got off the bike. I took off the left side fairing and found oil (at least I'm fairly certain it is) along the side of the engine. Mostly on the surfaces that are facing up.

    Bike info: 2004 RSVR; approx. 4900 miles; did oil change at approx 3100 miles; no mods other than Renthal grips; was working perfectly fine from the day I bought it till now.

    Currently it is at a local bike shop. When the key is turned to the "ON" position, the dash goes through the start-up sequence but the engine does not even crank. It's as if pressing you're not even pressing the ignition button. Absolutely nothing happens. I pray it's not something like a blown head gasket or something major. I live on the island of Oahu in Hawaii and there isn't a single shop that has any specialty tools for an Aprilia engine.

  2. #2
    Evil Twin theruck's Avatar
    Join Date
    May 2009
    Location
    Slovakia
    Posts
    472
    white smoke does mine when the oil from the air filter gets collected in the front part of the airbox and it drops on the exhaust pipe of the front cylinder. no big deal. but this happens only when the pipe is/is getting hot. on cold start i would guess that your problem will be electric. maybe some cable insulation got damaged and it short circuited something.

  3. #3
    Baby Twin seoulja702's Avatar
    Join Date
    Oct 2012
    Location
    Oahu, Hawaii
    Posts
    4
    I guess I'll have to drop by the bike shop where it's at and see if they found anything. How is it that the dash start-up sequence goes through normally but still not even a crank. Might have to trace the wiring from the ignition switch down. I hope it's just a simple fix, but with my luck, it's gonna cost mad cheddar.

  4. #4
    Evil Twin theruck's Avatar
    Join Date
    May 2009
    Location
    Slovakia
    Posts
    472
    maybe the cable to the starter is fried, maybe fuse, maybe maybe... you have to look

  5. #5
    Baby Twin seoulja702's Avatar
    Join Date
    Oct 2012
    Location
    Oahu, Hawaii
    Posts
    4
    Update: So the shop called today and said it was the immobilizer. They stated that the wires got fried. +1 for theruck! It is indeed electrical, now I just have to find a new one to replace it with. I don't even know what an immobilizer looks like.

  6. #6
    Baby Twin seoulja702's Avatar
    Join Date
    Oct 2012
    Location
    Oahu, Hawaii
    Posts
    4
    Update 2: Shop called again stating that they could get me a new immobilizer, however they asked for a "red tip" key. I looked at both my keys and they don't have any red tip. Supposedly they're used to program the new immobilizer. Anyone have any ideas on this new development?

  7. #7
    Evil Twin theruck's Avatar
    Join Date
    May 2009
    Location
    Slovakia
    Posts
    472
    somebody here stated that some BMW X5 key fit so you can have a look at those if you cant find aprilia genuine. or go without the imobilliseur if possible. nobody steals a motorcycle and drives it home on his own...

Similar Discussions

  1. Replies: 10
    Last Post: December 14th, 2011, 01:25 AM
  2. Rsvr 04 won't start
    By The Ring-In in forum Aprilia RSVR
    Replies: 6
    Last Post: October 15th, 2011, 04:02 AM
  3. beloing white smoke
    By joe46hills in forum Aprilia RSVR
    Replies: 4
    Last Post: June 12th, 2011, 11:30 AM
  4. 04 RSVR won't start!!
    By grahamir in forum Aprilia RSVR
    Replies: 13
    Last Post: April 29th, 2011, 11:20 PM
  5. 2000 RSVR wont start.
    By DrPMR in forum Aprilia RSV Mille
    Replies: 6
    Last Post: August 26th, 2008, 05:15 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •