Results 1 to 3 of 3

Thread: I got CHEATED by a local dealer!!!

  1. #1
    Baby Twin
    Join Date
    Sep 2013
    Location
    Malaysia
    Posts
    53

    Angry I got CHEATED by a local dealer!!!

    Hi Guys,

    Early January this year I got my self a 04' RSV 1000R Factory as most of you know, not even 2 weeks later it had a electrical charging problem, thus I sent it back to the local dealer... 3 weeks after, the dealer claimed the rectifier had issues and replace the rectifier.

    Yesterday the bike had simillar issue again, where it was not charging properly and the onboard voltage meter said only 9.9v instead of the normal 12-14v.

    So, I decided to open and check the bike... to my suprise I found that the "newly" replaced rectifier did not sit in properly in the in it's bracket... and finally found out that the rectifier fitted in my bike does not belong to RSV model but a Pegaso 2 model instead.

    Since the part is not a standard spec for the RSV, it burned out the connector and made the wires super hot!!!....

    I've sent a complaint to the local dealer and now awaiting response.

    here are some pictures:

    https://lh3.googleusercontent.com/-E...227_174152.jpg
    https://lh4.googleusercontent.com/-i...227_174144.jpg
    https://lh3.googleusercontent.com/-q...227_174239.jpg

    *not sure why, the the forum picture upload doesn't seem to work or I just dont know how to use it :

  2. #2
    Superbike Twin
    Join Date
    Oct 2010
    Posts
    129
    I'd check the stator too. Mine went, so replaced both that and the reg/rec, plus used 35amp (Halfords) heat shrinkable crimps, that connector isn't up to the job. Mines been fine since (3 years ago).

  3. #3
    Baby Twin
    Join Date
    Sep 2013
    Location
    Malaysia
    Posts
    53
    Quote Originally Posted by mark58 View Post
    I'd check the stator too. Mine went, so replaced both that and the reg/rec, plus used 35amp (Halfords) heat shrinkable crimps, that connector isn't up to the job. Mines been fine since (3 years ago).
    thanks bro, will check it.

    I changed my stator connector from the lousy white plastic to this for the time being. hopefully this wont burn...

    http://thumbs2.ebaystatic.com/d/l225...9LNzNC5eMA.jpg

Similar Discussions

  1. Local Bikeshop won't rivet EK chains ?!
    By gecco in forum Aprilia RSVR
    Replies: 5
    Last Post: April 8th, 2011, 12:43 AM
  2. Local RSV R ?
    By wanabe in forum Want to Buy
    Replies: 2
    Last Post: October 29th, 2009, 11:19 AM
  3. local yellow rsv
    By heroblob in forum Aprilia RSVR
    Replies: 21
    Last Post: April 11th, 2008, 03:17 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •