Results 1 to 9 of 9

Thread: Not running right

  1. #1
    Superbike Twin badapple's Avatar
    Join Date
    Apr 2013
    Location
    norwich
    Posts
    226

    Not running right

    Hi all
    My gen 2 rsvr isn't running as well as normal. The last two rides out it's a bit fluffy low in the revs and isn't pulling as cleanly once above 5k. It's not bad enough to ruin a ride but just doesn't seem quite right. I've changed the oil and filter this year and it had new plugs and air filter less than 1500 miles ago. Running map2 with arrows but otherwise standard. Throttle bodies? Fueling? Any advice appreciated.

  2. #2
    Baby Twin andreas's Avatar
    Join Date
    May 2011
    Posts
    90
    Take it to Griff @ Home - Aprilia Performance. Not too close to you, but well worth the trip . . . in spades . . .

  3. #3
    Superbike Twin badapple's Avatar
    Join Date
    Apr 2013
    Location
    norwich
    Posts
    226
    Yea it's a fair trek. There is an excellent Italian specialist Carl Harrison near me that I take her to for anything I can't or won't do myself but was hoping for a few ideas before calling the doctor. From being on here for a while now griff does seem to be the man in the know might give him a call if I can't work it out.

  4. #4
    Baby Twin
    Join Date
    Jul 2013
    Location
    Finland
    Posts
    18
    Get PCV and take it to dyno. Mine (Gen 2 with arrow cans) was like the same, not quite right on lower rpms. After tuning the PCV on dyno it is like a new bike. Silky smooth through the whole rpm range.

  5. #5
    Superbike Twin badapple's Avatar
    Join Date
    Apr 2013
    Location
    norwich
    Posts
    226
    Thanks I've been thinking of a PC or getting the ecu flashed might be time to finally get round to it.

  6. #6
    Superbike Twin RSV 69's Avatar
    Join Date
    Sep 2011
    Location
    BRACKLEY
    Posts
    224
    Throttle bodies probably need balancing

  7. #7
    Superbike Twin badapple's Avatar
    Join Date
    Apr 2013
    Location
    norwich
    Posts
    226
    Throttle bodies was my first thought tbh

  8. #8
    Baby Twin
    Join Date
    Jul 2013
    Location
    Finland
    Posts
    18
    Mine was impossible to get smooth to all areas with just tb sync.

  9. #9
    Superbike Twin badapple's Avatar
    Join Date
    Apr 2013
    Location
    norwich
    Posts
    226
    Well thrashed the he'll out of it round snetterton and it was spot on all evening so who knows what was up with her

Similar Discussions

  1. Remove key/keeps running
    By rsvr-lex in forum Aprilia RSVR
    Replies: 3
    Last Post: July 31st, 2013, 03:38 AM
  2. running probs
    By tommytwice in forum Aprilia RSVR
    Replies: 1
    Last Post: November 1st, 2010, 04:58 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •