Results 1 to 3 of 3

Thread: Intermittent Limp Mode

  1. #1
    Baby Twin RotaryBred's Avatar
    Join Date
    Nov 2009
    Location
    Meriden, CT
    Posts
    21

    Intermittent Limp Mode

    Hey all. I have an 04 RSVR. I've had no problems with it that weren't obvious fixes until yesterday. I started it up, let it warm up. Then I went down the street and came to a stop sign. The bike stalled out, which happens from time to time shortly after starting it with the current tune on my power commander. I started it up but now the bike was in limp mode with the oil light on. No triangle or EFI warning. I turned the key off then back on and started her up and all was well again. I immediately took her home. My oil level was fine, and I checked the connection on the oil pressure sensor and it was clean and tight. I also tried to read any codes that may have popped up but there was nothing in the memory. I was able to replicate the problem as well - bike stalls at a stop and then goes into limp mode upon starting, but clears with key off/on. I just ordered a new oil pressure sensor and expect it later this week with my luck it won't fix the issue. Does any one have any other ideas that might help me out?

  2. #2
    Baby Twin Travy14's Avatar
    Join Date
    Jul 2014
    Location
    Riverview, Fl
    Posts
    27
    My bike did this when I first got it and it turned out to be the plug under the tail was fried. I've had it over a year and after some wire maintenance it did it again. After I shut it off and started it again, it was good. It did it 3 times so I hard wired the sensor at the plug and problem went away.

  3. #3
    Baby Twin RotaryBred's Avatar
    Join Date
    Nov 2009
    Location
    Meriden, CT
    Posts
    21
    I had that same problem and fixed it the same way some time ago. This time I'm not getting the EFI and warning triangle as I was with the bad connector under the seat.

Similar Discussions

  1. 06 Tuono intermittent on and off 1 cylider
    By Sharry Beene in forum Mechanical and Technical
    Replies: 3
    Last Post: September 26th, 2015, 08:17 AM
  2. mille 03 intermittent diag 1
    By Kitto in forum New Users
    Replies: 10
    Last Post: May 9th, 2014, 12:59 PM
  3. electrical gremlin/ limp mode
    By stress in forum Aprilia RSVR
    Replies: 3
    Last Post: June 11th, 2013, 06:18 PM
  4. Red speedo backlight intermittent
    By Phil in forum Aprilia RSVR
    Replies: 3
    Last Post: November 7th, 2009, 12:35 PM
  5. Limp wristed
    By shady59 in forum Aprilia RSVR
    Replies: 2
    Last Post: May 11th, 2009, 01:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •