Results 1 to 5 of 5

Thread: RSV-R 2004 temperature reading issue

  1. #1
    Baby Twin
    Join Date
    Mar 2016
    Location
    Slovenia
    Posts
    5

    RSV-R 2004 temperature reading issue

    Does anyone have any experience with the flowing problem: (RSV-R 2004)
    Ones my machine temperature rises to aprox. 80 C or a bit over, I get an EFI alarm and the temperature jumps to 135 C (in a second) . I then stop the bike turn off the ignition and on again (immediately) and the temperature then drops back to 80C or something and I can continue riding for a few minutes and then I get the same thing again. I am almost shore that the temperature measurement is incorrect so: must be something wrong with the temperature sensor or...any suggestions?

  2. #2
    Retired
    Join Date
    Oct 2010
    Posts
    491
    Quote Originally Posted by MUSTANG View Post
    Does anyone have any experience with the flowing problem: (RSV-R 2004)
    Ones my machine temperature rises to aprox. 80 C or a bit over, I get an EFI alarm and the temperature jumps to 135 C (in a second) . I then stop the bike turn off the ignition and on again (immediately) and the temperature then drops back to 80C or something and I can continue riding for a few minutes and then I get the same thing again. I am almost shore that the temperature measurement is incorrect so: must be something wrong with the temperature sensor or...any suggestions?
    Look at this post on Rsvr.net - Gen 2 updated Temp sensor - RSVR.NET Forums

  3. #3
    Baby Twin
    Join Date
    Mar 2016
    Location
    Slovenia
    Posts
    5
    Quote Originally Posted by Spoonz View Post
    Look at this post on Rsvr.net - Gen 2 updated Temp sensor - RSVR.NET Forums
    Thanks for that. I'll check the sensor.

  4. #4
    Baby Twin
    Join Date
    Mar 2016
    Location
    Slovenia
    Posts
    5
    Is there any easy way to get the old sensor out? I've got the blue one so I probably need to change it...but from the first look it seems like now way to get a wrench inside there...

    image.jpeg

  5. #5
    Baby Twin
    Join Date
    Mar 2016
    Location
    Slovenia
    Posts
    5
    Do I need to take the engine out or is there an easyer way?

Similar Discussions

  1. Trip meter issue on 2004 2nd Gen Factory
    By PAL in forum Aprilia RSVR
    Replies: 1
    Last Post: April 11th, 2013, 01:02 AM
  2. 04+ Air Temperature Sensor
    By Garvey2003 in forum Want to Buy
    Replies: 3
    Last Post: June 25th, 2012, 03:06 AM
  3. Coolant Temperature indicator on
    By roughrider in forum Aprilia RSVR
    Replies: 6
    Last Post: June 17th, 2012, 11:59 PM
  4. temperature not accurate
    By akuNabil in forum Aprilia RSVR
    Replies: 3
    Last Post: February 17th, 2010, 02:10 AM
  5. Temperature sender.
    By Tingo in forum Aprilia RSVR
    Replies: 0
    Last Post: February 3rd, 2009, 08:59 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •