Results 1 to 3 of 3

Thread: 2007 Aprilia rsv1000 Bol D Or running problems

  1. #1
    Baby Twin
    Join Date
    Feb 2017
    Location
    united states
    Posts
    2

    2007 Aprilia rsv1000 Bol D Or running problems

    My bike keeps stalling after an hour of riding then it runs all screwy in 2nd gear it will speed up to about thirty mph and fall on its face speed up cut out speed up n cut out once it's cooled down an hour of riding same thing and I'm completely lost please help me out

  2. #2
    Superbike Twin Hertsrsvr's Avatar
    Join Date
    Feb 2017
    Location
    Herts, england
    Posts
    108
    Could it be a blocked tank breather ?
    Kinked or restricted would mean the fuel pump has to fight a vacuum in the tank.
    A blocked / restricted fuel filter.
    How old is the battery, so it charging well, full power , the regulator might be going wrong.

    That's just a few !

  3. #3
    Baby Twin
    Join Date
    Feb 2017
    Location
    united states
    Posts
    2
    Quote Originally Posted by Hertsrsvr View Post
    Could it be a blocked tank breather ?
    Kinked or restricted would mean the fuel pump has to fight a vacuum in the tank.
    A blocked / restricted fuel filter.
    How old is the battery, so it charging well, full power , the regulator might be going wrong.

    That's just a few !
    Vent was plugged solid but cleaned it out and filter is my next plan of attack it didn't start the funky off and on fuel problem until I put injector cleaner in it

Similar Discussions

  1. Running problems after10/15 miles
    By rsvhayd in forum Aprilia RSVR
    Replies: 12
    Last Post: May 13th, 2015, 06:16 AM
  2. 2007 RSVR running rough?
    By Olympic in forum Aprilia RSVR
    Replies: 11
    Last Post: January 20th, 2014, 12:39 PM
  3. 2001 rsv running problems after crash
    By brett668 in forum Aprilia RSV Mille
    Replies: 3
    Last Post: May 16th, 2012, 02:09 PM
  4. Running problems
    By gix2rsv in forum Aprilia RSVR
    Replies: 8
    Last Post: February 5th, 2011, 11:35 AM
  5. RSV Factory running problems?
    By 996_will in forum Aprilia RSVR
    Replies: 8
    Last Post: May 17th, 2009, 07:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •