Results 1 to 7 of 7

Thread: Newbie RSVR Gen 2 owner charging issue

  1. #1
    Baby Twin
    Join Date
    Jul 2017
    Location
    Lancaster UK
    Posts
    5

    Newbie RSVR Gen 2 owner charging issue

    Hi Guys,
    I bought a gen 2 RSVR 1000 about 3 weeks ago, I love it, however I went away to Turkey last week I've come back and it has stranded me twice with a flat battery after stalling out.
    It stalled a couple of times before I left but I just figured it needed a service/tune.
    I checked the VDC at the battery and no matter what revs its showing 12.25V and falling.
    So, Ive had the fairings off and I've found that someone has already done the charging mod as there is a choc block wound up with electrical tape coming out of the Reg/rec and 3 (green/yellow earth) 2.5mm leads going to the -presumably- stator.
    So, themod appears to be done (i've yet to lift the tank and follow it back as the mrs is giving me grief). The reg/rec is absolutely boiling after 30 seconds. Would it be safe to say that the reg/rec is goosed considering its getting hot and voltage- no matter what revs- is steady?
    Or do I need to check the stator?
    Do i check the voltages going to the reg/rec with the bike running?
    Any and all comments are appreciated

  2. #2
    Baby Twin sixshotdave's Avatar
    Join Date
    May 2015
    Location
    Redditch
    Posts
    24
    So first things first check whether it's charging by measuring voltage whilst running. If it's charging then rip the block off and solder the wires.
    Next I would change the Battery



    Sent from my iPhone using Tapatalk

  3. #3
    Baby Twin
    Join Date
    Jul 2017
    Location
    Lancaster UK
    Posts
    5
    thanks for the reply, checked battery while running, took it up to over 4000rpm stayed at 12.25 and slowly falling. I will solder it in the future, I just need to find out which parts faulty. I'm sending myself some info I can check at work today. I guess the next step is V ac between stator phases (with the bike running) at the choc block?

  4. #4
    Baby Twin
    Join Date
    Jul 2017
    Location
    Lancaster UK
    Posts
    5
    Well, sussed it. looks like my stator is fine, did a phase balance like I would on any induction motor all good - 0.2 ohms, voltage when revved rose to 67ish Vac phase to phase. looks like I'm only up for a reg/rec...hopefully. thanks sixshotdave for at least replying. seems a bit dead in here

  5. #5
    Superbike Twin Hertsrsvr's Avatar
    Join Date
    Feb 2017
    Location
    Herts, england
    Posts
    104
    Avoid cheap chinese reg/rec and get a mosfet regulator, search for threads. (Puts less strain on the alternator)

    It is dead on here

  6. #6
    Baby Twin sixshotdave's Avatar
    Join Date
    May 2015
    Location
    Redditch
    Posts
    24
    Yea very quiet on here get on Facebook the Aprilia Performance group. Great knowledge lots of help. Agree don't buy crap off eBay and upgrade your cables with a set from John Walker well worth it


    Sent from my iPhone using Tapatalk

  7. #7
    Baby Twin
    Join Date
    Jul 2017
    Location
    Lancaster UK
    Posts
    5
    Bugger! I've just bought a second hand OEM Reg/Rec from the same model off ebay for 45! I figured it was the safest bet.
    Aprilia RSV1000 R (3) 04' Rectifier regulator Regler Spannungsregler | eBay
    I looked at different types but there is too much conflicting info so I played it safe. I'll do a search and ask on FB

Similar Discussions

  1. Newbie with a starting issue
    By Lunar Effect in forum Aprilia RSV Mille
    Replies: 1
    Last Post: July 10th, 2016, 01:44 PM
  2. rsvr not charging
    By jonty in forum Aprilia RSVR
    Replies: 2
    Last Post: May 18th, 2014, 06:48 AM
  3. Another newbie owner
    By rumple in forum Aprilia RSVR
    Replies: 9
    Last Post: March 26th, 2012, 01:12 PM
  4. charging issue info! 04 onwards....
    By fusebox in forum Aprilia RSVR
    Replies: 7
    Last Post: August 25th, 2009, 09:40 AM
  5. Newbie 2001 RSV owner needs help!
    By rocketsy in forum Aprilia RSV Mille
    Replies: 11
    Last Post: March 31st, 2009, 02:54 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •