Results 1 to 6 of 6

Thread: STO Stepper control

  1. #1
    Baby Twin
    Join Date
    Jun 2014
    Location
    Wellingborough
    Posts
    31

    Unhappy STO Stepper control

    Hi My 05 Rsvr developed a fault where the red triangle is showing on the dash and You cannot accelerate hard as the bike is cutting off the throttle,bike has map 2 and Iv gone to RAD motorcycles in Northampton to connect it to the diagnostic tool to check what errors come up and on top of the error in the title there is also STO oxygen sensor,I know that on map 2 lambda sensor is turned off but it still has to be on the bike for it to work properly.What should I check/do to fix the issue?

  2. #2
    Super Moderator Tash's Avatar
    Join Date
    Mar 2009
    Location
    Co Durham
    Posts
    1,511
    I have got a dynojet 02 eliminator for sale if you want it, it plugs in in place of the original and you fit a bung in the exhaust where the original is fitted.

  3. #3
    Baby Twin
    Join Date
    Jun 2014
    Location
    Wellingborough
    Posts
    31
    Quote Originally Posted by Tash View Post
    I have got a dynojet 02 eliminator for sale if you want it, it plugs in in place of the original and you fit a bung in the exhaust where the original is fitted.
    Hi, will it fix both issues or just the lambda fault code?

  4. #4
    Baby Twin
    Join Date
    Jun 2014
    Location
    Wellingborough
    Posts
    31
    Please check this video and tell Me if the ICU needs changing as well,I took it out and cleaned it but I think this is still broken.
    https://www.youtube.com/watch?v=zLQj...ature=youtu.be

  5. #5
    Super Moderator Tash's Avatar
    Join Date
    Mar 2009
    Location
    Co Durham
    Posts
    1,511
    Quote Originally Posted by Statystyk View Post
    Hi, will it fix both issues or just the lambda fault code?
    I honestly couldn't say, but if the lambda is faulty then the bike will not run right

  6. #6
    Baby Twin
    Join Date
    Jun 2014
    Location
    Wellingborough
    Posts
    31
    Quote Originally Posted by Tash View Post
    I honestly couldn't say, but if the lambda is faulty then the bike will not run right
    Hi,got a lambda block installed and ICV from Peugeot 205 and now there seams to be an issue with fuel where the fuel light comes on and off even tough the bike is not low on fuel,it still goes into limp mode and wont let Me accelerate past 4.5k,I also felt some gasoline smell coming from the bike,do You think that this can be a fuel pump problem ?

Similar Discussions

  1. Traction Control on 1000R
    By GrandeCap in forum Aprilia RSVR
    Replies: 7
    Last Post: January 6th, 2014, 06:58 AM
  2. Air control valve in ram-air on 2nd gen
    By RotaryBred in forum Aprilia RSVR
    Replies: 12
    Last Post: August 4th, 2013, 05:50 AM
  3. Traction Control etc
    By spoonz in forum Aprilia RSV4
    Replies: 6
    Last Post: December 31st, 2009, 12:14 PM
  4. i2i Advanced machine control
    By Renevator in forum Motorcycle Talk
    Replies: 21
    Last Post: May 21st, 2008, 07:17 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •