Results 1 to 4 of 4

Thread: 2008 RSV Factory unsteady idle

  1. #1
    Baby Twin
    Join Date
    Nov 2017
    Location
    Gauteng
    Posts
    3

    2008 RSV Factory unsteady idle

    The bike has had a consistant idle and was a pleasure at stop lights. yesterday the idle falters after a while and then the engine cuts. I have checked for faults on diagnostic and all is clear. I find not leaks on the vacuum piping and bike starts well. The battery charges at 12,5V.
    the bike drives great in motion and throttle response is good.

    I just need to figure out the reason for this change in idle.

    Will check the stator output and voltage regulator tonight.

    any advice will be appreciated to help save me effort and time.

    Thanks

  2. #2
    Baby Twin
    Join Date
    Jun 2018
    Location
    UK
    Posts
    15
    Hi Brian,

    The battery charging at that voltage is a problem. You'll get problems with idle and cutting out. Something is away with the charging circuit, be it stator, rectifier or battery. Stator is a known issue with Gen 2 and there are loads of posts about it. You should have approx 60v AC at 4k rpm on all 3 phases or the stator is toast. Fitting a new stator no matter how industrial it claims to be will not fix the issue as the rotor generates so much current converts them into smoke if you're well heeled there's an updated stator and rotor combo available. Or it may just be the battery or the rec!

    As I'm not a millionaire I fitted a linear rectifier and a stator cooler, and mine's been spot on ever since, charging at 14v.

    Regards
    Ian

    Sent from my SM-G965F using Tapatalk

  3. #3
    Baby Twin
    Join Date
    Nov 2017
    Location
    Gauteng
    Posts
    3

    Charge definitely the problem

    Quote Originally Posted by Duggers View Post
    Hi Brian,

    The battery charging at that voltage is a problem. You'll get problems with idle and cutting out. Something is away with the charging circuit, be it stator, rectifier or battery. Stator is a known issue with Gen 2 and there are loads of posts about it. You should have approx 60v AC at 4k rpm on all 3 phases or the stator is toast. Fitting a new stator no matter how industrial it claims to be will not fix the issue as the rotor generates so much current converts them into smoke if you're well heeled there's an updated stator and rotor combo available. Or it may just be the battery or the rec!

    As I'm not a millionaire I fitted a linear rectifier and a stator cooler, and mine's been spot on ever since, charging at 14v.

    Regards
    Ian

    Sent from my SM-G965F using Tapatalk

    Thank you Duggers

    I have checked and got 12,4V charge back to the battery. The cycle is at the repairers now to get the charging sorted out. I have a repairer that specializes in our bikes. His brief report was that he will re-locate the voltage rectifier, repair the stator and install LED headlamps that draw less power.
    Thank you very much for your advice, I will probably collect my cycle Friday

    Cheers

    Brian

  4. #4
    Baby Twin
    Join Date
    Jun 2018
    Location
    UK
    Posts
    15
    Hi Brian,

    Thanks for responding.

    Many people don't understand the problem with the Gen 2, and changing the headlights to draw less power is the exact wrong thing to do! This will cause the standard rectifier to shunt its load to ground even more, and cause the stator to overheat and burn up even quicker. Seriously I advise against this approach.

    Regards
    Ian

    Sent from my SM-G965F using Tapatalk

Similar Discussions

  1. For sale OHLINS FORKS 2008 rsvr factory
    By Adam1984 in forum Classifieds
    Replies: 10
    Last Post: December 21st, 2015, 07:29 AM
  2. 2008 Rsv1000r Factory fairings!
    By Rsv08 in forum New Users
    Replies: 0
    Last Post: November 14th, 2015, 08:39 PM
  3. RSV R Factory 2008 for sale
    By Hutchie84 in forum Classifieds
    Replies: 7
    Last Post: February 6th, 2014, 11:55 PM
  4. Replies: 8
    Last Post: June 5th, 2013, 01:46 PM
  5. 06 Factory won't idle
    By Lag Junkie in forum Aprilia RSVR
    Replies: 4
    Last Post: June 10th, 2011, 02:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •