Results 1 to 8 of 8

Thread: Rough running

  1. #1
    Baby Twin V-twindude's Avatar
    Join Date
    Jul 2008
    Location
    UK
    Posts
    97

    Rough running

    Hi all,

    The bike has started running rough recently, its only done 7K miles and had its second service 1k ago. I'm wondering if it could be the spark plugs? I would have expected them to have lasted longer if this is the case. Its become really jerky at constant throttle or low revs, and at low speed feels like it wants to cut out on occasion.

    Also it seems to be using oil, no sign of any leaks on the garage floor. Is it common to burn oil? Seems odd! Any suggestions most welcome.

    Cheers

  2. #2
    LEGS
    Guest
    Could be the throttle bodies in need of adjustment to correctly set up the CO2 levels, poor low speed running and stalling are the usual symptons.

    Oil usage is one of those unknown mysteries on the rotax v twins, it can take 10000 miles before the engine is fully run in, it all depends on how hard the bike is used. Mine's only just stopped using oil and it's done 11700 miles
    Last edited by LEGS; July 20th, 2008 at 03:18 AM.

  3. #3
    spoonz
    Guest
    also check the miriad of vac pipes around the Tb's/ airbox for rubbing holes or disconnection. Especially the small ones on the left side.

  4. #4
    Baby Twin V-twindude's Avatar
    Join Date
    Jul 2008
    Location
    UK
    Posts
    97
    Thanks for the tips guys, i'll check it out

  5. #5
    Baby Twin V-twindude's Avatar
    Join Date
    Jul 2008
    Location
    UK
    Posts
    97
    Ok i've just changed the plugs, it seems to have made no difference. I've checked the hoses and electrical connectors around the airbox and they all seem fine.

    It seems to fire up pretty instantly and idles ok but doesnt rev properly, or hold a constant rpm. Its something that has come on recently so i'm wondering if something electrical ie sensor of somekind has failed or is malfunctioning as i cant imagine anything mechanical is worn or out of adjustment. Wouldnt the computer through up some kind of error message in this case? Also there is a bit of a intermittent screechy sound when idling from cold, coming from the rear of the engine area.

  6. #6
    LEGS
    Guest
    If you're sure there are no leaks on the vaccuum hoses as Spoonz suggests, then it probably an Aprilia dealer job. They will need to plug in the Axone diagnostics to check for fault codes. Out of sync throttle bodies can cause poor idling and low speed running but not to the extent of your symptoms unless something is way way out.

  7. #7
    spoonz
    Guest
    if you have another owner nearby try swapping the air pressure sensor on the left side under the seat. can be swopped in mins so no biggy.

    also check the vac pipe is still in place in the nose that controls the intake flap.

  8. #8
    Baby Twin V-twindude's Avatar
    Join Date
    Jul 2008
    Location
    UK
    Posts
    97
    Well just been away for the weekend on the bike, did about 550 mile and it hasnt missed a beat and seems to have cured itself

    Plus cruising in top at unmentionable speeds returned 48mpg. Its great to have the old girl back on form - chuffed!

    cheers

Similar Discussions

  1. Rough gear changes, Help please. (Gear shaft Removal)
    By millevanilli in forum Aprilia RSVR
    Replies: 7
    Last Post: October 26th, 2010, 12:29 AM
  2. fans not cutting in/running rough/sticky throttle
    By redratbike in forum Aprilia RSVR
    Replies: 12
    Last Post: January 31st, 2010, 06:46 AM
  3. haga side panel rough need pics please
    By oli in forum Aprilia RSVR
    Replies: 1
    Last Post: October 28th, 2009, 12:43 PM
  4. Selling up, or swap, rough value?
    By Anton2k3 in forum Aprilia RSVR
    Replies: 15
    Last Post: October 24th, 2009, 04:32 AM

Search tags for this page

Click on a term to search for related topics.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •