Results 1 to 12 of 12

Thread: rubbish battery?

  1. #1
    Baby Twin long face's Avatar
    Join Date
    Nov 2008
    Location
    riddings,derbyshire.
    Posts
    39

    rubbish battery?

    just tried starting my bike after a week,wont start,it turns over but wont fire the battery says 12.3 so should be fine but wont start.tried it 3 times so daren't try again (sprag) can anyone help...ta. oh! the bat is on optimate all the time

  2. #2
    amb67
    Guest
    Chances are your plugs will be soaked with fuel now.

    Best to pull them all out and dry them off, warm them up on a radiator in the house for an hour or so and then fit them to the bike.

    Have you done all the pre checks?

    Fuel pump primes and has fuel
    Alarm off
    No ECU messages on dash

  3. #3
    Baby Twin long face's Avatar
    Join Date
    Nov 2008
    Location
    riddings,derbyshire.
    Posts
    39
    there was a strong smell of petrol,there was no message on dash,doesn't have alarm,unfortunatly don't know what cheking fuel pump primes means.there is fuel in it..

  4. #4
    amb67
    Guest
    Quote Originally Posted by long face View Post
    there was a strong smell of petrol,there was no message on dash,doesn't have alarm,unfortunatly don't know what cheking fuel pump primes means.there is fuel in it..
    The fuel pump should buzz for a few seconds when you first turn the ignition on.

    These V Twins flood so easily and once flooded you have no chance of getting them going, not til the plugs dry out anyhow.

    I just fitted some iridium spark plugs to mine and it starts on the button every time now. Well worth the 25, plus I didn't have a clue how old the fitted ones were.

  5. #5
    Baby Twin long face's Avatar
    Join Date
    Nov 2008
    Location
    riddings,derbyshire.
    Posts
    39
    it makes all the right noises just wouldn't fire which is strange cos it's allways started first time for 2 years.i'll wait till it's dried out then have another go. do you think it's as simple as just cold weather? don't usually touch it till march time....cheers

  6. #6
    BB1000
    Guest
    State of Charge

    12.80v ........................ 100% Charged

    12.60v ........................ 100% Charged

    12.40v ........................ 75% Charged

    12.10v ........................ 50% Charged

    11.90v ........................ 25% Charged

    less than 11.80v .......... 0% Charged

  7. #7
    Superbike Twin colinpp's Avatar
    Join Date
    Jul 2008
    Location
    Cheltenham, UK
    Posts
    147
    Mate

    I reckon it might be time to look for a new battery. Back before Christmas mine wouldn't start even though it's always hooked up to the optimate and I use the bike at least once a week. Fitted the larger capacity battery recommended on this forum and it now starts instantly first time every time.

  8. #8
    Gasboy
    Guest
    Yeah same as above post !! New battery and get a bigger 1 !

  9. #9
    Superbike Twin p.ludlow's Avatar
    Join Date
    Nov 2008
    Location
    newark
    Posts
    148
    Quote Originally Posted by Gasboy View Post
    Yeah same as above post !! New battery and get a bigger 1 !
    Same again bigger battery,yam sol and irdium plugs bloody big change starts first time every time.

  10. #10
    Superbike Twin
    Join Date
    Sep 2007
    Location
    St.Helens.
    Posts
    199
    Big is best(battery)!!!And new plugs.AL

  11. #11
    Mick Oliver
    Guest
    Quote Originally Posted by p.ludlow View Post
    Same again bigger battery,yam sol and irdium plugs bloody big change starts first time every time.
    Same here first time every time fast idle press button and bursts into life

  12. #12
    AMA Pit Boss Sprocker's Avatar
    Join Date
    Oct 2010
    Location
    Pontefract, W.Yorks
    Posts
    4,335
    Quote Originally Posted by BB1000 View Post
    State of Charge

    12.80v ........................ 100% Charged

    12.60v ........................ 100% Charged

    12.40v ........................ 75% Charged

    12.10v ........................ 50% Charged

    11.90v ........................ 25% Charged

    less than 11.80v .......... 0% Charged
    Good post BB

Similar Discussions

  1. Normally rubbish at pictures ...
    By Wavey in forum Pictures
    Replies: 16
    Last Post: October 10th, 2009, 06:41 AM
  2. what to do while the weather is rubbish
    By kevcole in forum Aprilia RSVR
    Replies: 6
    Last Post: August 5th, 2009, 11:32 AM
  3. 03 rear brake rubbish
    By steppy78 in forum Aprilia RSVR
    Replies: 3
    Last Post: June 26th, 2009, 01:15 PM
  4. im rubbish
    By philandpa in forum Aprilia RSVR
    Replies: 27
    Last Post: May 1st, 2009, 10:59 AM
  5. Hit rubbish... then the deck.
    By Flick in forum Aprilia RSVR
    Replies: 23
    Last Post: August 30th, 2008, 04:02 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •