Results 1 to 10 of 10

Thread: Bike cutting out, maybe bad earth?

  1. #1
    Superbike Twin
    Join Date
    Jul 2008
    Location
    Belfast
    Posts
    167

    Bike cutting out, maybe bad earth?

    I have an 03 rsv and recently it has developed a strange problem.

    A few times when sitting at lights etc the bike has just suddenly died like the main fuse has gone. I turn off the key and turn it back on again but get the 4 clicks and kph change as the clocks reset. the bike then starts fine.

    Then today a more extreme one happened, riding to work the problem happened in a filter lane to turn right, everything went dead so turned the key off and back on a few times but still totally dead, pushed the bike across 2 lane dual carriageway at 850am (not for the faint hearted) and poked and prodded and 10 mins later it fired up fine.

    The one odd thing is that when it happened i turned the key off and back on again but still dead but it was then as i turned the key back off that the clocks would click and reset.

    Battery terminals are tight, how would i checked for bad earthing or any other ideas? Thanks in advance

  2. #2
    fusebox
    Guest
    Quote Originally Posted by r896neo View Post
    I have an 03 rsv and recently it has developed a strange problem.

    A few times when sitting at lights etc the bike has just suddenly died like the main fuse has gone. I turn off the key and turn it back on again but get the 4 clicks and kph change as the clocks reset. the bike then starts fine.

    Then today a more extreme one happened, riding to work the problem happened in a filter lane to turn right, everything went dead so turned the key off and back on a few times but still totally dead, pushed the bike across 2 lane dual carriageway at 850am (not for the faint hearted) and poked and prodded and 10 mins later it fired up fine.

    The one odd thing is that when it happened i turned the key off and back on again but still dead but it was then as i turned the key back off that the clocks would click and reset.

    Battery terminals are tight, how would i checked for bad earthing or any other ideas? Thanks in advance
    its defo a loose connection somewhere dude! please just check the terminal on the starter solenoid follow the red battery lead back to the solenoid if your not sure where it is ....sorry if granny suck eggs!

    also check the three earth points on the bike give them a good hard wiggle mate, follow the earth strap give it a good tug! (hehe) one above the swing arm pivot and one around the headstock!

    im confident its sommat loose dude!

  3. #3
    Superbike Twin
    Join Date
    Jul 2008
    Location
    Belfast
    Posts
    167
    thanks a lot griff i really appreciate it. i thought it seemed like an earth problem but wasn't sure how many or where the points where. Will get to it.

  4. #4
    B o B
    Guest
    I had some doubts about my earth connection about 18 months ago so I installed a new earth strap from the battery to the frame. This was in addition to the existing one(s). 20 minute job and never had reason to doubt it since. I'd already checked everything Griff mentioned.
    I admit this sounds a bit paranoid but you can't be too careful about the electrics on these machines.

  5. #5
    camngetit
    Guest
    somthing similar happenend to me yesterday and today . low on fuel i put in 3.00 worth (all i had on me )on way home from work low fuel light flashing on and off .rolling up to traffic lights it just died on me cut out as if it had been turned off . tried to restart but it was as if the battery was flat clocks went to kph pushed it to pavement and sat for 10 mins or so fired up and slowly went last 1/2 mile home up hill low rpm bike not feeling right as i turned in to my road it stopped again . pushed it home put it on charge put in a gallon of petrol fired up fine . next morning filled tank went for a ride poss 10 miles in slowing for a hump back bridge it felt chuggy opened it up all fine but as i changed gear it cut out as if it wouldnt idle same again kpm and no start bumped it and road home keeping rpm up got home and it was idling fine .took seat off prodding wires if i pushed the alarm wiring at the main loom joints it cuts out like it runs out of fuel . i have disconnected the 2 immob circuits but kept the alarm on as i dont really want to take it off if i dont have too .only prob is the alarm wont turn off so i have took the fuse out stuffed rags at the siren and letting it go off til the int battery runs flat . been out for a short ride and it was fine but it was only a short jaunt 8 ish miles . would this be the earths . the alarm (datatool evo) or pump wiring help !!!!

  6. #6
    camngetit
    Guest
    i did check the battery and charging it was at 14 v down to 13.7/8 when i got home second time

  7. #7
    Evil Twin RSV-TWIN's Avatar
    Join Date
    Apr 2009
    Posts
    491
    same here... but only on starting... in the last 3 days... iv switched the key on... let it do its checks... then pushed the starter... the rev counter would wriggle about 5 times really quickly from 0rpms to 2000rpms... then the dash would go off completely... which stops the engine from turning over... without touching the ignition key or anything else... the clocks then all come on again instantly & the clocks would all be reset to KPH/ZERO etc... once clocks reset & done its checks... itll start 1st time as normal... so there must be enough ooomph in the battery... lol... & i now know the resetting buttons off the top of my head... luckily its only happened 2 out of maybe 30 starts... maybe every 15 starts... still worrying though... as maybe it might progress to when im in moving traffic !?


    think il check my earths & fuses too !!

  8. #8
    AMA Pit Boss
    Join Date
    Sep 2008
    Location
    Shoeburyness, Essex
    Posts
    2,338
    The earth wire is connected to the rear cyclinder head with a shitty 6mm bolt , this earth wire corrodes and breaks easily.
    I have made my own earth which also goes to the frame and the engine from the battery.
    Also check the charging circuit connectors are not corroded as that can affect charging.

  9. #9
    camngetit
    Guest
    brown 3 pin yellow wire connector is very clean will check the earths at weekend

  10. #10
    Superbike Twin
    Join Date
    Jul 2008
    Location
    Belfast
    Posts
    167
    mine fixed with simply removing the ground straps from the earthing point on the frame (just under the base of the tank on the brake pedal side) and cleaning them all with emery.

    Good luck

Similar Discussions

  1. Please help!Bike cutting out
    By Zedhead in forum Aprilia RSVR
    Replies: 3
    Last Post: June 6th, 2012, 11:01 AM
  2. Bike cutting out
    By Phil in forum Aprilia RSVR
    Replies: 10
    Last Post: December 8th, 2009, 01:16 AM
  3. Reg/Rec Earth??
    By A303 in forum Aprilia RSVR
    Replies: 9
    Last Post: November 10th, 2009, 04:19 AM
  4. Bike cutting out
    By Kiwi_rsvr in forum Aprilia RSVR
    Replies: 21
    Last Post: October 13th, 2009, 10:52 AM
  5. Earth Locations
    By pjefferi in forum Aprilia RSVR
    Replies: 3
    Last Post: March 1st, 2009, 06:37 AM

Search tags for this page

Click on a term to search for related topics.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •