Page 3 of 3 FirstFirst 123
Results 41 to 59 of 59

Thread: Inexpensive speedo sensor fix

  1. #41
    Baby Twin
    Join Date
    May 2012
    Posts
    32
    well...it works Into ear to ear grin figures too.

    This is the one I installed:

    E2A-M12KS04-WP-C1 2M | OMRON Industrial Automation

    Which cost all of 1 + p&p. New old stock off fleabay. Have found them for 95 new elsewhere.

    Set it in the old sensor housing with silicon. Wiring as per pistonbrokes original post - hats off to him. Currently using new bolts with a larger head at the moment but will try it with the original ones and see if they work at some point.

  2. #42
    Baby Twin
    Join Date
    Oct 2010
    Location
    Near Lancaster
    Posts
    54
    Any chance of a link to the fleabay item, i can't seem to find them anywhere

  3. #43
    Baby Twin
    Join Date
    May 2012
    Posts
    32
    You won't mate - it was a one off. You just need a hall effect sensor the same spec as the one pistonbroke used - 12v DC Inductive NPN Normal Open 3 wire switching ~200Hz or above, and it needs to be ballpark the right physical size so it will fit. I was just looking for one with a recognised brand name as I was taking a guess that they go through more rigorous quality control than the cheap ones available direct from china on ebay.

    proximity (switch,sensor) -(ribbon,iphone,car,case,cable,tag) | eBay

    Just check the specs on the manufacturer website to be sure before you buy.

  4. #44
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9

    speedo fixed cheap!

    I fixed my one this weekend I'll add photos and video later
    Attached Images Attached Images
    Last edited by simifeltham; February 21st, 2015 at 11:17 AM.

  5. #45
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9

  6. #46
    Superbike Twin
    Join Date
    Oct 2010
    Posts
    138
    Quote Originally Posted by simifeltham View Post
    Can you post the details of what sensor you used etc? Cheers

  7. #47
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9
    same as pistonbroke mentioned on 1.st page from ebay for 3.70 , 10 days to arrive ,,lot of pix in my album as well

  8. #48
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9
    Quote Originally Posted by RSV MENACE View Post
    hi i bought 1 of these fitted and sort of works if im taking it easy upto 40mph its fine any faster or try to accelerate fast from stand still it jump all over the place iv changed the bolts so there flat and not domed in still the same a got it as close as pos without it touching any ideas im puzzled anyone els had this
    my one is doing exactly the same thing did you solve this problem?

  9. #49
    Baby Twin
    Join Date
    May 2015
    Location
    United Kingdom
    Posts
    1
    Hi just done the mod, using your link so same part & spec. Speedo works up to 50 mph and then goes to zero. Do you have any advice or idea what the problem may be?

  10. #50
    Baby Twin Gray's Avatar
    Join Date
    Apr 2015
    Location
    Doncaster
    Posts
    49
    Quote Originally Posted by Fast Yellow View Post
    Hi just done the mod, using your link so same part & spec. Speedo works up to 50 mph and then goes to zero. Do you have any advice or idea what the problem may be?
    I can't understand why anyone would waste so much time and energy trying to fix a problem with components that were not designed for the specific purpose of being a speed sensor for a motorbike. I'm all for saving time and cash (where appropriate ) but considering that I have not seen any evidence that this "mod" actually works on any ape forum, I'm dumbfounded that so many are even attempting this. Apart from anything else the finished product looks bloody awful.
    I also had a knackered speedo sensor cable and found a "new & unused old stock item" from a bike shop in Scotland for 72 fitted in 30 mins - job done.

    However each to their own

    Gray

  11. #51
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9
    my one does the same no proper reading over 50 , bought a ducati monster one, cut off the ducati connector ,connect the 3 pin aprilia mille one ,use some power to bend the ducati cable because that one is in different angle, job done ,works fine since then for 25 ..��

  12. #52
    Baby Twin Gray's Avatar
    Join Date
    Apr 2015
    Location
    Doncaster
    Posts
    49
    Quote Originally Posted by simifeltham View Post
    my one does the same no proper reading over 50 , bought a ducati monster one, cut off the ducati connector ,connect the 3 pin aprilia mille one ,use some power to bend the ducati cable because that one is in different angle, job done ,works fine since then for 25 ..��
    Please post a pic of the finished "mod"

    Gray

  13. #53
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9

  14. #54
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9
    even the color code of wires is the same on ducati speedo

  15. #55
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9
    Quote Originally Posted by Gray View Post
    Please post a pic of the finished "mod"

    Gray
    done mate

  16. #56
    Baby Twin
    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    9

  17. #57
    Baby Twin Gray's Avatar
    Join Date
    Apr 2015
    Location
    Doncaster
    Posts
    49
    I take back some of my previous comments, the final appearance looks better than I expected. However it will be interesting to see how long it functions properly. If it was mine I would be concerned that I had introintroduced 2 areas of potential failure:
    1 a "bent" sensor connector
    2 a jointed cable

    But I am a pessimist by nature, and I hope that all is well with the work you have done.

    Gray

  18. #58
    Baby Twin echelon's Avatar
    Join Date
    Sep 2012
    Posts
    60
    11650715_1026083520737904_1361102345_n.jpg11650834_1026083494071240_922317074_n.jpg

    Great piece of advice! DC 12-24V NPN 3-wire 2mm Approach Inductive Proximity Sensor Switch PR12-2-DN from ebay. I used the old mounting and drilled out the middle. Put stainless steel allen bolts in. The allen bolts have a bigger lump of metal at the end and not the big dip in the middle especially if you grind the bolts flat. It takes a bit of setting up to get the right distance which is very close, just pray there is no play in your back wheel bearing. A little bit of heat shrink to cover the threads to finish.

  19. #59

Page 3 of 3 FirstFirst 123

Similar Discussions

  1. speedo sensor
    By RSV 69 in forum Aprilia RSVR
    Replies: 1
    Last Post: May 11th, 2012, 02:07 PM
  2. Speedo sensor
    By PaulW in forum Aprilia RSVR
    Replies: 1
    Last Post: May 4th, 2012, 12:33 AM
  3. Speedo sensor
    By Wavey in forum Aprilia RSVR
    Replies: 5
    Last Post: October 7th, 2009, 11:02 AM
  4. speedo sensor
    By murfeey in forum Aprilia RSVR
    Replies: 2
    Last Post: July 12th, 2009, 10:07 AM
  5. Speedo sensor
    By caterpillar in forum Aprilia RSVR
    Replies: 2
    Last Post: June 25th, 2008, 08:21 AM

Search tags for this page

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •