Results 1 to 4 of 4

Thread: right side of dashboard not working

  1. #1
    Baby Twin
    Join Date
    Oct 2018
    Location
    Oregon
    Posts
    4

    right side of dashboard not working

    Noob here, Hello everyone, I have recently purchased a 2001 Aprilia Mille. The right side of the dashboard does not function after the initial computer check. During the initial computer check, it shows the coolant temperature and the clock. Almost immediately the coolant temp and clock disappear and the word "diag" with the number 1 below that appear and remain for the entire time the engine is running. ( It worked only once, during the time it worked, I was able to reset the temperature to F, and do the clock settings, it has not worked since that time.) Any thoughts on what could be wrong please?

  2. #2
    Retired
    Join Date
    Oct 2010
    Posts
    502
    you've got the dash in diag mode. Unplug the bullet connector under the seat on the right side and it will be normal again.

  3. #3
    Baby Twin
    Join Date
    Oct 2018
    Location
    Oregon
    Posts
    4
    Quote Originally Posted by Spoonz View Post
    you've got the dash in diag mode. Unplug the bullet connector under the seat on the right side and it will be normal again.
    Hi, Thanks for your suggestion, there are 5 connectors under the seat. I unplugged them one at a time, turned on the ignition, started the engine, and each time it was still in diag mode. I also tried unplugging two at a time, same results. Could my diag connector be in a different position?

  4. #4
    Baby Twin
    Join Date
    Oct 2018
    Location
    Oregon
    Posts
    4
    I finally found the right connector tucked under some other wires. Thank you Spoonz, much appreciate your help.

Similar Discussions

  1. Buying an RSV need help with ERR code on dashboard.
    By AdamBignell in forum Mechanical and Technical
    Replies: 4
    Last Post: November 21st, 2016, 02:18 AM
  2. Replies: 6
    Last Post: April 25th, 2013, 02:23 PM
  3. Cracked dashboard lens
    By markps in forum Aprilia RSVR
    Replies: 1
    Last Post: October 3rd, 2011, 09:09 AM
  4. Dashboard bulbs
    By Alan Haskins in forum Aprilia RSVR
    Replies: 0
    Last Post: January 17th, 2010, 01:59 AM
  5. Dashboard problem - any ideas?
    By beechy in forum Aprilia RSVR
    Replies: 9
    Last Post: July 3rd, 2008, 02:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •