Results 1 to 3 of 3

Thread: Dr Rossi ECU issues

  1. #1
    Baby Twin
    Join Date
    Aug 2009
    Posts
    1

    Exclamation Dr Rossi ECU issues

    Hello all,

    Recently tried to install a Dr Rossi ECU into my 2002 RSV and it won't take.

    For some reason the bike goes into some form of a "limp mode" very slow acceleration. Put the original ecu back in and off I went with no hesitation, no issues.

    I suppose from that analysis I am looking at it being an issue with the Dr Rossi ECU !

    Anyone got any ideas ? Suggestions ?

  2. #2
    AMA Pit Boss redratbike's Avatar
    Join Date
    Oct 2010
    Location
    Modding collectors in kent
    Posts
    2,967
    New chip time I think

  3. #3
    Superbike Twin flatlander's Avatar
    Join Date
    Sep 2011
    Location
    cheshire uk
    Posts
    176
    Get a magnifying glass and.make sure tge chip and pins are correctly seated and none are broken if not as red says ...

Similar Discussions

  1. Immobilizer issues
    By Pac man in forum Aprilia RSVR
    Replies: 2
    Last Post: February 10th, 2017, 11:22 PM
  2. Indicator Issues, please help..
    By taliesinjami in forum Aprilia RSVR
    Replies: 9
    Last Post: October 9th, 2012, 09:46 PM
  3. Hi I'm new with issues
    By caveman47 in forum Aprilia RSVR
    Replies: 8
    Last Post: November 12th, 2009, 07:28 AM
  4. EFI Issues
    By Garvey2003 in forum Aprilia RSVR
    Replies: 7
    Last Post: November 26th, 2008, 04:54 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •